GPF with SVGALib 
Author Message
 GPF with SVGALib

I'm writing an SVGALib wrapper for my gl... anywho.. I've gotten all the
basic routines down such as vga_setmode/hasmode and ect.. however when I
included gl_setpixel/gl_setpixelrgb my program gets runtime error 216
(General Protection Fault/ Segment Fault) when I call them.

As far as I can tell there is nothing wront with my code.  it exicutes
fine even uptill it reaches my wrapper routine, but once it calls
ql_setpixel it segfaults.  I can't figure out why.  There are no linking
issues during compilation.  And my program can call vga_setmode/hasmode
fine, without error.



Tue, 20 Apr 2004 02:35:43 GMT  
 GPF with SVGALib

Quote:

> I'm writing an SVGALib wrapper for my gl... anywho.. I've gotten all the
> basic routines down such as vga_setmode/hasmode and ect.. however when I
> included gl_setpixel/gl_setpixelrgb my program gets runtime error 216
> (General Protection Fault/ Segment Fault) when I call them.

> As far as I can tell there is nothing wront with my code.  it exicutes
> fine even uptill it reaches my wrapper routine, but once it calls
> ql_setpixel it segfaults.  I can't figure out why.  There are no linking
> issues during compilation.  And my program can call vga_setmode/hasmode
> fine, without error.

Hard to say without code, and I'm not a GL expert. Could be a calling convention
or callback problem?


Tue, 20 Apr 2004 06:15:38 GMT  
 
 [ 2 post ] 

 Relevant Pages 

1. Update: GPF with SVGALib

2. -lvga error from svgalib demos compile

3. X or SVGALib bindings for FPK

4. Sybase dll GPF'ing

5. Using TTables, GPF's

6. GPF in Module IDPDX01.DLL at 0008:00CB

7. App GPF closing because

8. Sybase GPF'ing problem

9. App GPF closing because Report Smith ?

10. Multiple apps using IB causing GPF's

11. (fwd) Re: GPF errors from IDAPI01.DLL

12. BDEcfg32 gives GPF...please help !

 

 
Powered by phpBB® Forum Software