EDBEngineError: Master record missing 
Author Message
 EDBEngineError: Master record missing

Program gives the EDBEngineError: Master record missing.

Could anyone help me with this error? I can't find anything useful in
the printed documentation or the (new) on-line help.

The circumstances are:

Delphi 2 Developer.
Paradox DB.
Table has data source with various bound controls.
Program does:
 tbl.Append;
 tbl.FieldValues ('field1') := value;
 tbl.FieldValues ('field2') := value;
 tbl.Append;
Error occurs at the second Append.

---------------------------------------------------

                                                http://www.*-*-*.com/ ~martin/
[if possible, please send any replies both to the newsgroup and direct
to me by email]



Sat, 19 Dec 1998 03:00:00 GMT  
 EDBEngineError: Master record missing

It sounds like you have referential integrity established between the
table you are appending to and another table holding acceptable
values for one of the fields.  The value of one of the fields you have
edited after the first append is not in the master table.  When you do
the second append it first tries to post the first and fails because of
the missing master.  Make sure the value in the field with the integrity
defined is contained in the master table before you try the post, or try
to post before the second append and trap the error and deny the second
append until corrected.  You can also programatically allow the user to
add the new value to the master table on the fly, then repost the
problem record, although that tends to result in garbage values getting
added to the master.

Quote:

> Program gives the EDBEngineError: Master record missing.

> Could anyone help me with this error? I can't find anything useful in
> the printed documentation or the (new) on-line help.

> The circumstances are:

> Delphi 2 Developer.
> Paradox DB.
> Table has data source with various bound controls.
> Program does:
>  tbl.Append;
>  tbl.FieldValues ('field1') := value;
>  tbl.FieldValues ('field2') := value;
>  tbl.Append;
> Error occurs at the second Append.

> ---------------------------------------------------

>                                                 http://www-comp.mpce.mq.edu.au/~martin/
> [if possible, please send any replies both to the newsgroup and direct
> to me by email]

--




Sat, 19 Dec 1998 03:00:00 GMT  
 
 [ 2 post ] 

 Relevant Pages 

1. Missing master records in Paradox tables

2. EDBEngineError - Missing Comma

3. Changing Key Fields in Master Record without Orphaning Detail Records

4. DBLookupComboBox: EDBEngineError 'No Current record'

5. EdbEngineError - Record/Key deleted

6. EDBEngineError "Record lock failed message"

7. D2: EDBEngineError: 'Record/key deleted'

8. EDBEngineError..."Record/Key deleted"

9. missing records

10. Cached Updates Problem: Missing Records - Bogus RecordCount

11. Missing Records with Stored Procedures and SQL Server 6.5

12. Missing First Two Chars of SQL Memo and Missing SQL Fields

 

 
Powered by phpBB® Forum Software