Quick Report preview bug? 
Author Message
 Quick Report preview bug?

Does anyone know if there is a way round this problem?
I have a report created with Quick Report 2.0i which prints just fine
but has a QRlabel which will simply not preview properly.
The caption is set programatically as it refers to a date - I have
done this in the 'before print' method and have the code copied at
another point in the program in case the before print event is not
triggered before a preview. When simply printing the form everything
updates and prints out as it is supposed to - so no problems there.
When previwing it truncates the QRlabel width property to 34 instead
of 128.
I have spent quite a bit of time debugging this and have determined
that the caption property is set as intended and the label width is
still 128 until the QReport1.Preview code is executed.
If I pause the program while the previewed form is being displayed
everything crashes with a 'divide by zero' error in the user.exe
(windows). This is making pinpointing the problem rather difficult!
I can get back to delphi by selecting 'Close Project' and starting
over.

Any sugestions?



Wed, 18 Jun 1902 08:00:00 GMT  
 Quick Report preview bug?

Have you try upgrading to 2.0k?  (It's available on QuSoft's web site.)
Many bugs were fixed in 2.0k--for me the fixes in the handling of carriage
returns in memo fields have been something I've been waiting for since I
started with 2.0b back in May 1997.  Good luck.
Gene



Quote:
> Does anyone know if there is a way round this problem?
> I have a report created with Quick Report 2.0i which prints just fine
> but has a QRlabel which will simply not preview properly.
> The caption is set programatically as it refers to a date - I have
> done this in the 'before print' method and have the code copied at
> another point in the program in case the before print event is not
> triggered before a preview. When simply printing the form everything
> updates and prints out as it is supposed to - so no problems there.
> When previwing it truncates the QRlabel width property to 34 instead
> of 128.
> I have spent quite a bit of time debugging this and have determined
> that the caption property is set as intended and the label width is
> still 128 until the QReport1.Preview code is executed.
> If I pause the program while the previewed form is being displayed
> everything crashes with a 'divide by zero' error in the user.exe
> (windows). This is making pinpointing the problem rather difficult!
> I can get back to Delphi by selecting 'Close Project' and starting
> over.

> Any sugestions?



Wed, 18 Jun 1902 08:00:00 GMT  
 Quick Report preview bug?

Quote:
>Have you try upgrading to 2.0k?  (It's available on QuSoft's web site.)
>Many bugs were fixed in 2.0k--for me the fixes in the handling of carriage
>returns in memo fields have been something I've been waiting for since I
>started with 2.0b back in May 1997.  Good luck.
>Gene

Gene,
even look like the same problem I had with Quick{*filter*}2.0* ( sorry.... ;-) )
since V2.0b and many upgrades I went back to Quickreport 1.1b for D3.
And no more problems left ( especially converting D2 -> D3 )....

  Sven



Wed, 18 Jun 1902 08:00:00 GMT  
 Quick Report preview bug?


Quote:

>Does anyone know if there is a way round this problem?
>I have a report created with Quick Report 2.0i which prints just fine
>but has a QRlabel which will simply not preview properly.
>The caption is set programatically as it refers to a date - I have
>done this in the 'before print' method and have the code copied at
>another point in the program in case the before print event is not
>triggered before a preview. When simply printing the form everything
>updates and prints out as it is supposed to - so no problems there.
>When previwing it truncates the QRlabel width property to 34 instead
>of 128.
>I have spent quite a bit of time debugging this and have determined
>that the caption property is set as intended and the label width is
>still 128 until the QReport1.Preview code is executed.
>If I pause the program while the previewed form is being displayed
>everything crashes with a 'divide by zero' error in the user.exe
>(windows). This is making pinpointing the problem rather difficult!
>I can get back to Delphi by selecting 'Close Project' and starting
>over.

>Any sugestions?

To reply to my own question - the people ar QuSoft pointed out that
the height property may need to be increased. This did the trick so no
more problem. It seems that as I had wordwrap set true there was not
enough height avaiable to wrap the text - albeit out by only one
pixel.


Wed, 18 Jun 1902 08:00:00 GMT  
 
 [ 4 post ] 

 Relevant Pages 

1. Quick Reports Preview Print Problem

2. Quick Reports Preview Window

3. QUICK REPORT BUG ?

4. quick reports quick questions!

5. Crystal Report, Quick Report - where to get ?

6. Quick Reports Composite report Delphi 7 question

7. Advice please - writing Report Preview capability

8. Tip: How to put a Crystal Reports preview-window on the Window pulldown

9. ReportSmith Previewing Reports

10. Positioning Rave report print preview window?

11. Report Smith Bugs (master/detail reports)

12. Quick Report ? Bug Empty pages in reports (Help please)

 

 
Powered by phpBB® Forum Software