Delphi 5 and MS Access 97 passing of Strings 
Author Message
 Delphi 5 and MS Access 97 passing of Strings

I am having problems passing string as parameters in a TQuery.

I am also not able to search the Access 97 database using strings.

I am on Windows 95, MS Office 97 and delphi 5.

I am connecting to Access with the the BDE and the MS Access 97 OBDC driver.

Any suggestions as to my problem?

Thanks in advance,

Dave



Sat, 15 Nov 2003 13:55:33 GMT  
 Delphi 5 and MS Access 97 passing of Strings
Dave,
Can you post a  copy the code where you assign the parameter values to
the Query? I suspect you need to have some quotes included in the
strings that you are passing. You might try
        sql.parambyname(param1).AsString := quotedstr(mypraramvar1);
instead of
        sql.parambyname(param1).AsString := mypraramvar1;

HTH,
Dan


Quote:
>I am having problems passing string as parameters in a TQuery.

>I am also not able to search the Access 97 database using strings.

>I am on Windows 95, MS Office 97 and Delphi 5.

>I am connecting to Access with the the BDE and the MS Access 97 OBDC driver.

>Any suggestions as to my problem?

>Thanks in advance,

>Dave

--
Dan Brennand
CMDC systems, inc.
Configuration Management and Document Control:
visit us at www.cmdcsystems.com



Sun, 16 Nov 2003 12:40:39 GMT  
 
 [ 2 post ] 

 Relevant Pages 

1. Accessing MS Access 97 data from Delphi 3

2. Access 97 report from Delphi and passing parameters

3. Delphi components for MS Access 95/97/2000

4. Delphi 3 and MS Access 97

5. MS Access 97 with Delphi 4

6. Delphi 3 pro & MS Access 97

7. HELP: MS Access 97 & Delphi 3

8. Delphi 3.0 vs MS Access 97

9. Delphi 3 and MS Access 97 NOT!

10. D4 - MS Access 97 - MDAC 2.* TTable Access violations

11. Access to MS Access 97 in D2

12. Problems with ACCESS 97 and empty strings

 

 
Powered by phpBB® Forum Software