"At beginning of Table" 
Author Message
 "At beginning of Table"

Hello there, ive just started with a database application in Delphi. I
have a problem adding records to a database and then displaying these
records in a dbgrid. I get the error "At beginnning of table" whenever
i try to click on the record that i just added in the grid. Anyone ?

thanx&bye
email reactions please

Scout Kirk Olson



Sat, 13 Feb 1999 03:00:00 GMT  
 "At beginning of Table"

Is there a good book or any other source available that shows in detail
how to call and make use of the Windows API or Win32 API functions?

There is a book for Visual Basic called "Programmers Guide to the Win32
API" by Daniel Appleman. Is there such a thing for Delphi 2.0?

--
Thomas Jaeger
CZAR Software
http://www.execpc.com/~czarsoft



Sat, 13 Feb 1999 03:00:00 GMT  
 "At beginning of Table"


Quote:
>Hello there, ive just started with a database application in Delphi. I
>have a problem adding records to a database and then displaying these
>records in a dbgrid. I get the error "At beginnning of table" whenever
>i try to click on the record that i just added in the grid. Anyone ?
>thanx&bye
>email reactions please
>Scout Kirk Olson


Did you Post the row to the database?


Sat, 13 Feb 1999 03:00:00 GMT  
 "At beginning of Table"


Quote:

>Subject: "At beginning of Table"
>Date: 27 Aug 1996 00:25:54 GMT
>Hello there, ive just started with a database application in Delphi. I
>have a problem adding records to a database and then displaying these
>records in a dbgrid. I get the error "At beginnning of table" whenever
>i try to click on the record that i just added in the grid. Anyone ?
>thanx&bye
>email reactions please
>Scout Kirk Olson


Kirk:

I need more info - what kind of database are you using?  Are you using the
autoedit property on the datasource or are you explicitly calling the insert
and post methods for the table?  Are you even using a ttable or a tquery to
insert the data?

-Dave



Sun, 14 Feb 1999 03:00:00 GMT  
 "At beginning of Table"

You've got a blob or memo field in this grid, don't you?  I've had
the same problem, but haven't seen a way to fix it yet.  Instead, I
just disallow in-place editing (kinda defeats the purpose of using
a dbgrid I know, but what can I do?).

 In article

Quote:



>>Subject: "At beginning of Table"
>>Date: 27 Aug 1996 00:25:54 GMT

>>Hello there, ive just started with a database application in Delphi. I
>>have a problem adding records to a database and then displaying these
>>records in a dbgrid. I get the error "At beginnning of table" whenever
>>i try to click on the record that i just added in the grid. Anyone ?

>>thanx&bye
>>email reactions please

>>Scout Kirk Olson

>Kirk:

>I need more info - what kind of database are you using?  Are you using the
>autoedit property on the datasource or are you explicitly calling the insert
>and post methods for the table?  Are you even using a ttable or a tquery to
>insert the data?

>-Dave



Tue, 16 Feb 1999 03:00:00 GMT  
 
 [ 7 post ] 

 Relevant Pages 

1. "At beginning of Table"

2. EDBEngineError "At beginning of Table" (D1)

3. BDE error "At beginning of table"

4. "At beginning of table" error

5. "At beginning/end of table"

6. "At Beginning of Table" errors in TQuery

7. Need help on "At beginning of Table" BDE error 34 message ?

8. Getting message "at beginning of table" ????

9. BDE Error (bug?) : "At beginning of table"

10. The keys "-"/"+"/"*"

11. ""256 Color Mouse""

12. "Lost OF TABLE-Symbols"

 

 
Powered by phpBB® Forum Software