Report Smith, Delphi 1, and Paradox 9 compatibility 
Author Message
 Report Smith, Delphi 1, and Paradox 9 compatibility

I have an old delphi 1 application I built for a customer using a
Paradox database the BDE and Report Smith runtime. The customer has
upgraded Paradox to Corel Paradox 9 and now the reports don't work. When
Report Smith runtime starts up it complains about an outdated version.
Does anybody have any idea what can be done (if anything) to make the
reports work again. does it require an updated rs_run? Where do you get
this. I think it originally came with Delphi, but I can't find any
Report Smith stuff with Delphi 5 (my current version).

Thanks,
Glen



Thu, 07 Aug 2003 02:08:53 GMT  
 Report Smith, Delphi 1, and Paradox 9 compatibility

Quote:

> I have an old Delphi 1 application I built for a customer using a
> Paradox database the BDE and Report Smith runtime. The customer has
> upgraded Paradox to Corel Paradox 9 and now the reports don't work. When
> Report Smith runtime starts up it complains about an outdated version.
> Does anybody have any idea what can be done (if anything)

I have never used Report Smith, but I quess there are two things to
check:

1. Do you have BDE 2.5x, the 16-bit version installed? The 16 and 32
   bit BDE versions can easily co-exist in the same W95/98/W2000 machine,
   and they do not harm each others.

2. I don't know about the Report Smith runtime modules. In general
   the old D1 RSmith reports run fine also on W95/98 versions.
   I quess re-installing the old RS version could fix the problem.

   If I remember it right, Borland dropped RS from Delphi package
   after D1, or at least after D2 version and replaced it with
   QReport. So, you'll maybe have to get the original D1 package
   somewhere.

   Report Smith's new home page is here http://www.srs-inc.com/

Markku Nevalainen



Thu, 07 Aug 2003 07:26:32 GMT  
 Report Smith, Delphi 1, and Paradox 9 compatibility
: I have an old Delphi 1 application I built for a customer using a
: Paradox database the BDE and Report Smith runtime. The customer has
: upgraded Paradox to Corel Paradox 9 and now the reports don't work. When
: Report Smith runtime starts up it complains about an outdated version.
: Does anybody have any idea what can be done (if anything) to make the
: reports work again. does it require an updated rs_run? Where do you get
: this. I think it originally came with Delphi, but I can't find any
: Report Smith stuff with Delphi 5 (my current version).

Delphi 1 and the RS that came with it use the 16-bit BDE, so
installing 32-bit Paradox 9 shouldn't have made a difference,
AFAIK.  This is the same computer that was running your apps
properly before, and it has all the proper 16-bit BDE and RS
Runtime files installed?  Have you tried reinstalling those files?

Nope, the last RS was packaged with Delphi 2, and after that Borland
dumped the product (sold it off), deciding they were better off
concentrating on programming languages, which they do very well,
rather than end-user products.  If you anticipate developing new
reports, it may be time to look at another report builder.
--
Rick Carter



Fri, 08 Aug 2003 10:02:16 GMT  
 Report Smith, Delphi 1, and Paradox 9 compatibility
Thanks for the responses folks! I'll try all your suggestions on Tuesday.

Glen Stone



Fri, 08 Aug 2003 10:45:18 GMT  
 
 [ 4 post ] 

 Relevant Pages 

1. Report Smith: Cannot connect to paradox

2. Report Smith and report variables

3. REPORT VARIABLE: REPORT SMITH

4. Report Smith & Report variables

5. Report Smith Bugs (master/detail reports)

6. Delphi /w Report Smith Runtime?

7. Will Delphi 2.0 Fix Report Smith?

8. Report Smith and Delphi

9. Report Smith in Delphi 3

10. * Size of DELPHI (BORLAND) REPORT SMITH runtime *

11. Problems with Report Smith in Delphi 1

12. Report Smith and Delphi 1.0

 

 
Powered by phpBB® Forum Software