Missing First Two Chars of SQL Memo and Missing SQL Fields 
Author Message
 Missing First Two Chars of SQL Memo and Missing SQL Fields

The problem that many of us encountered with missing the first two
characters of a DB Memo field from SQL is corrected by the latest
delphi update CD-Rom. However, read on:

In the latest CD_Rom, fields were missing in BDE when they were added
at the SQL level.

The problem appears to be a bug in either the SQL ODBC driver or it's
interface in DBE. (I'm using Sybase SQL Anywhere as a DBMs) Delphi BDE
or its ODBC cannot handle "long varchar" or "text" field types.
Regular "varchar" is OK.

When BDE encounters a "long varchar" type field, it stops
reading/looking for more fields and DOES NOT report the error. If you
try to access some other field which falls after the "long varchar"
field, it reports that the field does not exist.

This problem is not present in the original Delphi 2.0 CD-Rom.

For me, the work-around was to convert the "long varchar" fields to
simple "varchar".



Sat, 20 Feb 1999 03:00:00 GMT  
 
 [ 1 post ] 

 Relevant Pages 

1. TMemoField Bug? missing first 2 chars

2. Q: I miss the first letter

3. Q: I miss the first letter

4. Missing first character using before insert with dbgrid

5. "Missing comma" error with SQL statement

6. BDE Missing ) error message on SQL statement

7. Missing Records with Stored Procedures and SQL Server 6.5

8. Delphi 2 DB Missing Fields?

9. Error with a missing FIELD

10. Interbase--Append--Required Field missing

11. DataBaseModule and Missing Values in Field which is required one

12. SQL and sorting two fields

 

 
Powered by phpBB® Forum Software