Help. I lost my auto-increment column 
Author Message
 Help. I lost my auto-increment column

Help. I lost my auto-increment column.

I had a column of autoincrement fields. One of the indexes got
corrupted and I did a table repair on it.

When I inspected the new table, I saw that THE AUTO INCREMENT COLUMN
RESET ITSELF STARTING AT 1.

has this happened to you?

Which Table Repair utility should I be using?



Tue, 29 Jun 1999 03:00:00 GMT  
 Help. I lost my auto-increment column

Ted:

It is a function of the version...

Get the latest TUTIL & BDE. There is a link to the correct Borland page
on our components page below. (I got tired of typing it in :-)  )

WIN32 - 3.52 , TUTIL 3.50 OK I think
WIN16 - 2.52 , TUTIL 2.52

This bug was driving people crazy. We *think* it is fixed now.

The x.52 versions apparently have a bug with International char. sets
-So be warned if you are shipping product outside the country!

Quote:

> Help. I lost my auto-increment column.

> I had a column of autoincrement fields. One of the indexes got
> corrupted and I did a table repair on it.

> When I inspected the new table, I saw that THE AUTO INCREMENT COLUMN
> RESET ITSELF STARTING AT 1.

> has this happened to you?

> Which Table Repair utility should I be using?

--
___________________
Regards,
Dave Robinson, VP Development
Amber Computer Systems Inc.

WEB page: http://mindlink.net/amber_computer/
Components Page: http://mindlink.net/amber_computer/comp01.htm

ASAP-RTS Manufacturing Scheduling and shop floor data collection with
bar coding, and product tagging.  
Databases from directories - an OCR and Scanning system to create
marketing databases from directories.



Tue, 29 Jun 1999 03:00:00 GMT  
 Help. I lost my auto-increment column


Quote:

>I had a column of autoincrement fields. One of the indexes got
>corrupted and I did a table repair on it.

>When I inspected the new table, I saw that THE AUTO INCREMENT COLUMN
>RESET ITSELF STARTING AT 1.
>Which Table Repair utility should I be using?

In addition to my other response, ( I still recommend not using
autoincrement fields to relate tables ), I just found this at borland:

http://www.*-*-*.com/

TUtility DLL v2.52. This DLL is the version shipping with Paradox 7
for Win3.1 and WFW3.11. This version will not change AutoIncrement
field values. This DLL must be used in conjunction with the BDE v2.52
16-Bit core DLLs (~1.7M) or TUtility will not work correctly.

As it say, make sure you are using the right BDE (v2.52 for 16 bit).
You can download it from the same page.

Chuck Gadd
Director of Software Development, {*filter*} FX Communications.

Remove the - in front of my email address to send me e-mail.
This prevents automailers from filling my mailbox!
*** I boycott businesses that send me unsolicited email adverti{*filter*}ts ***



Fri, 02 Jul 1999 03:00:00 GMT  
 Help. I lost my auto-increment column


Quote:

>When I inspected the new table, I saw that THE AUTO INCREMENT COLUMN
>RESET ITSELF STARTING AT 1.

>has this happened to you?

>Which Table Repair utility should I be using?

My understanding (very basic at this point) is that is normal behavior
for an auto-increment field.

I have seen many posts that recommend against using an auto-increment
as a primary key.

I just added a NewKey table, with a single field containing the next
key.  When the app wants to add a new record, it locks the NewKey
table, gets the value of the next key, increments it, and unlocks.

Chuck Gadd
Director of Software Development, {*filter*} FX Communications.

Remove the - in front of my email address to send me e-mail.
This prevents automailers from filling my mailbox!
*** I boycott businesses that send me unsolicited email adverti{*filter*}ts ***



Fri, 02 Jul 1999 03:00:00 GMT  
 Help. I lost my auto-increment column

If you are using Borlands TUtil32.dll to repere paradox tables use
latest version 3.5 (at least 3.12) I preserves autoincremet field (does
not reset it) Go to Borland BDE Home page, download latest TUtil32.dll
and you can also use repare utility from the same home page

Quote:



> >I had a column of autoincrement fields. One of the indexes got
> >corrupted and I did a table repair on it.

> >When I inspected the new table, I saw that THE AUTO INCREMENT COLUMN
> >RESET ITSELF STARTING AT 1.

> >Which Table Repair utility should I be using?

> In addition to my other response, ( I still recommend not using
> autoincrement fields to relate tables ), I just found this at borland:

> http://www.*-*-*.com/

> TUtility DLL v2.52. This DLL is the version shipping with Paradox 7
> for Win3.1 and WFW3.11. This version will not change AutoIncrement
> field values. This DLL must be used in conjunction with the BDE v2.52
> 16-Bit core DLLs (~1.7M) or TUtility will not work correctly.

> As it say, make sure you are using the right BDE (v2.52 for 16 bit).
> You can download it from the same page.

> Chuck Gadd
> Director of Software Development, {*filter*} FX Communications.

> Remove the - in front of my email address to send me e-mail.
> This prevents automailers from filling my mailbox!
> *** I boycott businesses that send me unsolicited email adverti{*filter*}ts ***



Sun, 04 Jul 1999 03:00:00 GMT  
 
 [ 5 post ] 

 Relevant Pages 

1. D2/MSSQL Auto-increment (identity columns) not working

2. Need help defining auto-incrementing field using TTable.Create

3. HELP auto increment and dbi functions

4. Need Help With Auto-Increment Primary Key Errors

5. Auto increment field

6. Master-detail and auto-increment fields

7. Auto Increment Fields and Master Details Relationship

8. Question about auto increment field

9. MS Access Auto incrementing Key fields

10. Delphi 2 SQL Server 6 problem with identifier (auto-increment) fields

11. auto-increment

12. Auto-increment fields - Should I Use Them?

 

 
Powered by phpBB® Forum Software