Possible bug in BDE ? (SQL troubles) 
Author Message
 Possible bug in BDE ? (SQL troubles)

Hy All,

When I try to run the following query (in 32bit BDE v.3.12 or v3.5):

        select equipeNummer
        from prores
        where prores.proefNummer < 2

I get a 'General Protection Fault' in the Database Desktop
and a 'Access Violation' in the delphi IDE.

When I try:

        select equipeNummer
        from prores
        where prores.proefNummer = 2

I get the correct results. Is this a bug in the BDE of am I
doing something wrong ?

  _   ___  _____

 | |( (__   | |   ICT Automatisering Deventer B.V.   Tel: 0570-633888
 |_| \___/  |_|   "Nieuwe wegen in automatisering"   Fax: 0570-621362



Sun, 27 Jun 1999 03:00:00 GMT  
 Possible bug in BDE ? (SQL troubles)

Hy All,

When I try to run the following query (in 32bit BDE v.3.12 or v3.5):

        select equipeNummer
        from prores
        where prores.proefNummer < 2

I get a 'General Protection Fault' in the Database Desktop
and a 'Access Violation' in the Delphi IDE.

When I try:

        select equipeNummer
        from prores
        where prores.proefNummer = 2

I get the correct results. Is this a bug in the BDE of am I
doing something wrong ?

  _   ___  _____

 | |( (__   | |   ICT Automatisering Deventer B.V.   Tel: 0570-633888
 |_| \___/  |_|   "Nieuwe wegen in automatisering"   Fax: 0570-621362



Mon, 28 Jun 1999 03:00:00 GMT  
 Possible bug in BDE ? (SQL troubles)


Quote:
>When I try to run the following query (in 32bit BDE v.3.12 or v3.5):
>        select equipeNummer
>        from prores
>        where prores.proefNummer < 2
>I get a 'General Protection Fault' in the Database Desktop
>and a 'Access Violation' in the Delphi IDE.
>When I try:
>        select equipeNummer
>        from prores
>        where prores.proefNummer = 2

You are using only 1 table, so why use prores.proefNummer in your
where instead of just proefNummer. Perhaps this is the reason of the
fault.


Tue, 29 Jun 1999 03:00:00 GMT  
 
 [ 3 post ] 

 Relevant Pages 

1. Possible bug in BDE

2. D2: Possible BDE bug.

3. possible BDE Transaction bug

4. Possible bug: Delphi 2.0/MS SQL 6.0/numeric or decimal fields

5. Strange problem using local SQL / BDE 3.5 (bug?)

6. tquery.SQL.Add..having trouble passing sql string

7. Possible bug in lookup fields

8. POSSIBLE BUG in cached update

9. Possible bug in VCL code for TPasswordEvent ???

10. Possible Bug in Typed Constants

11. TP/BP7 CRT bug - no source code available - a possible fix

12. gvision - Possible Bug

 

 
Powered by phpBB® Forum Software