'Invalid ROWID' With Delphi 5 and Oracle 8.0.5.0.0 Enterprise on NT 
Author Message
 'Invalid ROWID' With Delphi 5 and Oracle 8.0.5.0.0 Enterprise on NT

Please Help!!!

I have a system written in delphi 5 with Oracle as the database.  We have
been running this system on various versions of Delphi over the last 3 years
and have just upgraded to Oracle 8.0.5.0.0 Enterprise on NT.  The system was
on Oracle 7.3.4 Enterprise on NT.  With the upgrade the system returns a
INVALID ROW ID error when a post is performed by the Delphi Prog.  I have
been up for 48 hours now trying to fix this problem and cannot find a
solution.  We have installed a database patch to upgrade Oracle to 8.0.5.2.6
which is supposed to fix the problem, but has not.  Oracle support are not
really interested as they say it is a Delphi problem.  I am using the
standard BDE for the system.

Regards

John Groome



Wed, 18 Jun 1902 08:00:00 GMT  
 'Invalid ROWID' With Delphi 5 and Oracle 8.0.5.0.0 Enterprise on NT

Actually, seems to me that you made a problem.
Have you checked fields at your TQuery and so components?
If you did any alterations to database, and forgot to update fields, stored proc. mapping parameters and so, that is the problem.
Happens to me often.

BTW, Oracle isn't saint and it is much more buggy than interbase and unnecessarely complex. Complexity - more errors.

---
FA Beli/Fleet Commader/PLT Loch/ISF
[MoIx4][IDMx2][SSx2][GS][MoH]
ISF-1998030106
http://www.imperialstarfleet.com
---
Jedi Master Beli/ATD/Dark Council/Advisor of SoH
[VC][CD][BTM][STM][GTM][GSC]
http://www.sauron.co.yu/atd
---
http://www.sauron.co.yu
ICQ No. 1878554

Quote:
  ----- Original Message -----
  From: John Groome

  Sent: Tuesday, 11 July, 2000 10:53 AM
  Subject: 'Invalid ROWID' With Delphi 5 and Oracle 8.0.5.0.0 Enterprise on NT

  Please Help!!!

  I have a system written in Delphi 5 with Oracle as the database.  We have
  been running this system on various versions of Delphi over the last 3 years
  and have just upgraded to Oracle 8.0.5.0.0 Enterprise on NT.  The system was
  on Oracle 7.3.4 Enterprise on NT.  With the upgrade the system returns a
  INVALID ROW ID error when a post is performed by the Delphi Prog.  I have
  been up for 48 hours now trying to fix this problem and cannot find a
  solution.  We have installed a database patch to upgrade Oracle to 8.0.5.2.6
  which is supposed to fix the problem, but has not.  Oracle support are not
  really interested as they say it is a Delphi problem.  I am using the
  standard BDE for the system.

  Regards

  John Groome



Wed, 18 Jun 1902 08:00:00 GMT  
 
 [ 2 post ] 

 Relevant Pages 

1. Solution: Oracle 8, Delphi 3, Invalid rowid

2. oracle 8: ORA-01410 invalid rowid

3. Help!: 'Invalid variable reference'

4. EDBEngineError 'Invalid File Name'

5. EVariantError 'Invalid variant type conversion'

6. 'Invalid Filename' - BDE Error

7. 'Unable to Open' error in NT

8. Delphi and Oracle 8 rowid problems

9. GetEnv('COMSPEC') under NT

10. Delphi 3 (+BDE4.51) and Oracle 8 ROWID problem

11. ORA-01410 invalid ROWID

12. Delphi and Oracle Enterprise Server 7

 

 
Powered by phpBB® Forum Software