Field 'xxxxx' not fount 
Author Message
 Field 'xxxxx' not fount

Dear all:
  I use ADO in my Application. I use a qry
and its SQL.Text is below:
  "Select TSRValue.Value From TSRValue, Service_Grp
   Where TSRValue.GrpID = Service_Grp.GrpID
   And Service_Grp.GrpName = :GrpName"
TSRValue is a table name. It has two fields(GrpID
and TSRValue). Service_Grp is also a table name.
It has fields(GrpID, GrpName, Description). When I
exec the query, the application shows me an error
message: qryTSRValue: Field 'TSRValue' not found.
Is anything I do wrong? Thanks all.

                                      hagar.



Wed, 13 Aug 2003 18:57:11 GMT  
 Field 'xxxxx' not fount

Quote:

>Dear all:
>  I use ADO in my Application. I use a qry
>and its SQL.Text is below:
>  "Select TSRValue.Value From TSRValue, Service_Grp

Should be 'Select TSRValue.TSRValue....'  I think.

Quote:
>   Where TSRValue.GrpID = Service_Grp.GrpID
>   And Service_Grp.GrpName = :GrpName"
>TSRValue is a table name. It has two fields(GrpID
>and TSRValue). Service_Grp is also a table name.
>It has fields(GrpID, GrpName, Description). When I
>exec the query, the application shows me an error
>message: qryTSRValue: Field 'TSRValue' not found.
>Is anything I do wrong? Thanks all.

>                                      hagar.

Just a hint: if you can, change the name of this field to something
other than the table name, to avoid confusion. (I suspect you
inherited this, and can't change it ;-)

HTH,
Dan
--
Dan Brennand
CMDC systems, inc.
Configuration Management and Document Control:
visit us at www.cmdcsystems.com



Thu, 14 Aug 2003 03:01:23 GMT  
 Field 'xxxxx' not fount
Thanks for your answering.
Finally, I found the solution. I changed the
Table name first. But the problem is not solved.
Then I tried to click the right button on the
Query componet. I select "Add All Fileds". It
appeared the field "TSRValu", then my problem
is solved. :)

                                hagar.



Fri, 15 Aug 2003 08:51:01 GMT  
 
 [ 3 post ] 

 Relevant Pages 

1. Field 'PHYSICALTYPE' not found

2. Query:Field 'fieldname' not found

3. Creating RunTime Fields: EDataBaseError 'Field 'Fieldname' is not of the expected type'

4. type field ''money''

5. 'Metafile is not valid'

6. Error: 'Capability not supported'

7. 'Cancel' does not work

8. BDE 'Could not find object'

9. TQuery problem -- 'Table Does Not Exist'

10. 'Operation not applicable' on Table filter

11. Workaround for 'nested selects not supported'?

12. TBatchMove component gives - 'Not Supported' Error

 

 
Powered by phpBB® Forum Software