Delphi doesn't use Paradox Validations 
Author Message
 Delphi doesn't use Paradox Validations

Why is is that when I set up a property for a field in a Paradox database
(eg. Required or Mask) it doesn't enforce these properties in a delphi
form?

Also, I used Database desktop to create several Paradox 7 tables, but when
I use database explorer to examine the tables it states that they are
Paradox 4 tables.



Sat, 29 Aug 1998 03:00:00 GMT  
 Delphi doesn't use Paradox Validations

Quote:

>Why is is that when I set up a property for a field in a Paradox database
>(eg. Required or Mask) it doesn't enforce these properties in a Delphi
>form?

>Also, I used Database desktop to create several Paradox 7 tables, but when
>I use database explorer to examine the tables it states that they are
>Paradox 4 tables.

Paradox tables use the lowest version they can.  If all of the field types in
your table were supported in version 4, it uses version 4.  If you use a field
type that isn't in version 4 later on, your table will automatically be
updated.


Mon, 31 Aug 1998 03:00:00 GMT  
 Delphi doesn't use Paradox Validations

Quote:

>Why is is that when I set up a property for a field in a Paradox database
>(eg. Required or Mask) it doesn't enforce these properties in a Delphi
>form?

>Also, I used Database desktop to create several Paradox 7 tables, but when
>I use database explorer to examine the tables it states that they are
>Paradox 4 tables.

For some unknown reason Delphi 1.0 only uses the Paradox validations when
performing the post.  I know it's boring, but you can use the fields editor to
add them into the Delphi app.  In Delphi 2.0 it's easiest to add the validations
inside a data dictionary; this way if you change the backend database your
validations will still exist.

I believe that Paradox tables are reported as being from the lowest version
number of the Paradox database format that they are compatible with.
You probably aren't using any V7 of V5 only features.

Smiler.



Wed, 02 Sep 1998 03:00:00 GMT  
 
 [ 3 post ] 

 Relevant Pages 

1. QReport doesn't work when native connection to MS Access 97 is used

2. Delphi's DB Engine and Server Data Validation

3. Tdbedits and Paradox Validation in Delphi V1

4. Delphi+ODBC+BDE+SqlServer doesn't work

5. Delphi 2.0 - Data Pump doesn't work......

6. LookUp and Fill, Why Doesn't it work in Delphi(Like in DBDT)

7. Delphi: TDBGrid doesn't fill completely

8. Delphi doesn't read ODBC Field Defaults.

9. TQuery's locate method doesn't work properly

10. Why using Oracle Objects for OLE 2.0 from Delphi 2.0 doesn't work ?

11. Weird msg with Delphi/MS SQL 'table doesn't exist'

12. SQL-Monitor doesn't trace...?

 

 
Powered by phpBB® Forum Software