Why is OS/2 st80 so slow? 
Author Message
 Why is OS/2 st80 so slow?

Hi folks,

I would like to the call the attention of st80 (OS/2) performance gurus.

We have an st80 (VisualWorks 1.0) application that runs with very
reasonable response times on Windows (on the pentium PC). The application
is intensively into interactive graphics -- with frequent displays of
images, masks, vector points, lines and areas and patterns. There is also a
fair amount of disk i/o to read the data. We were foolish enough to buy the
propoganda about complete portability to different platforms and brought up
the image on the OS/2 VM a week before the delivery date.

        THE SYSTEM IS TRAUMATICALLY SLOWER (especially the graphics).

Can the guru please enlighten us on the following:
1. Is the st80 OS/2 VM inherently several times slower (for graphics) than
the Windows VM (in which case we are screwed)?
2. Are there known configuration tweeks for OS/2 relating to:
   a. The Virtual Memory settings, cache size etc.
   b. Specific display drivers.
3. Are there any other other magic wands that you are aware of?

I am in the process of running the profiler on both the Windows and
the OS/2 application, and understanding the differences. Any
recommendations would be most helpful.

Thanks in advance.

Raju Chithambaram
voice: 612 644-6064



Sun, 22 Jun 1997 02:54:48 GMT  
 Why is OS/2 st80 so slow?
: Hi folks,

: I would like to the call the attention of st80 (OS/2) performance gurus.

: We have an st80 (VisualWorks 1.0) application that runs with very
: reasonable response times on Windows (on the pentium PC). The application
: is intensively into interactive graphics -- with frequent displays of
: images, masks, vector points, lines and areas and patterns. There is also a
: fair amount of disk i/o to read the data. We were foolish enough to buy the
: propoganda about complete portability to different platforms and brought up
: the image on the OS/2 VM a week before the delivery date.
:                
:         THE SYSTEM IS TRAUMATICALLY SLOWER (especially the graphics).

: Can the guru please enlighten us on the following:
: 1. Is the st80 OS/2 VM inherently several times slower (for graphics) than
: the Windows VM (in which case we are screwed)?
: 2. Are there known configuration tweeks for OS/2 relating to:
:    a. The Virtual Memory settings, cache size etc.
:    b. Specific display drivers.
: 3. Are there any other other magic wands that you are aware of?

: I am in the process of running the profiler on both the Windows and
: the OS/2 application, and understanding the differences. Any
: recommendations would be most helpful.

: Thanks in advance.

What is your hardware and software configuration?
I don't think OS/2 version of st80 runs slower than Windows.  In fact
I seen run Smalltalk app runs decent on oS/2.  Had you talked with ParcPlace?

-- sehyo chang



Sun, 22 Jun 1997 04:35:24 GMT  
 Why is OS/2 st80 so slow?

Quote:

>Hi folks,

>I would like to the call the attention of st80 (OS/2) performance gurus.

>We have an st80 (VisualWorks 1.0) application that runs with very
>reasonable response times on Windows (on the pentium PC). The application
>is intensively into interactive graphics -- with frequent displays of
>images, masks, vector points, lines and areas and patterns. There is also a
>fair amount of disk i/o to read the data. We were foolish enough to buy the
>propoganda about complete portability to different platforms and brought up
>the image on the OS/2 VM a week before the delivery date.

>        THE SYSTEM IS TRAUMATICALLY SLOWER (especially the graphics).

>Can the guru please enlighten us on the following:
>1. Is the st80 OS/2 VM inherently several times slower (for graphics) than
>the Windows VM (in which case we are screwed)?
>2. Are there known configuration tweeks for OS/2 relating to:
>   a. The Virtual Memory settings, cache size etc.
>   b. Specific display drivers.
>3. Are there any other other magic wands that you are aware of?

Well, I am running VW on a pentium under OS/2 2.11 and its response seems fine.
A couple things to consider;
1. Running VW under OS/2 requires more memory than windows to run well.  Try
   increasing the amount of real memory to see if the situation changes.
2. Some video card vendors have done a poor job of providing adequate OS/2 drivers.
   This may be a potential source of problems.  The vendor of my card, Matrox,
   has done a poor job, I am planning to replace the card with one of the ATI Mach 64
   cards, primarily because all reports indicate that the drivers are much better.

Quote:

>I am in the process of running the profiler on both the Windows and
>the OS/2 application, and understanding the differences. Any
>recommendations would be most helpful.

>Thanks in advance.

>Raju Chithambaram
>voice: 612 644-6064

Terry

--
Terry Raymond                          Telephone: 1-401-846-6144



Sun, 22 Jun 1997 04:29:49 GMT  
 
 [ 3 post ] 

 Relevant Pages 

1. The Smalltalk Store: Why we've been slow, and why we're getting better

2. slow - am I asking too much

3. ST80 for OS/2

4. Status of st80 for OS/2

5. ST80 for OS/2

6. ST80-R4 and OS/2

7. St80->ObjectiveC & Dist.St80

8. why why why oh why why baby

9. Why am I getting bind errors?

10. ERROR 48 - Why am I getting it?

11. why am i getting processor stack fault error?

12. Why I am not enthusiatic about OO COBOL

 

 
Powered by phpBB® Forum Software