Problem with Smalltalk Application on WindowsNT 3.51 
Author Message
 Problem with Smalltalk Application on WindowsNT 3.51

I am testing a custom Smalltalk application (written for WindowsNT4.0)
on a WindowsNT 3.51 machine. When I launch the app, I get this error
message: "missing 1 in cwcswin"  I did not write the application and
have been given the task of testing it for our WindowsNT 3.51 users.
Has anybody ever seen this or heard of this error. The error causes
the app to close right after launch. I have searched for an answer
everywhere, including smalltalk support. Thanks in advance for your
help.

Manuel Rodriguez-Perez
Technical Services
Florida Power and Light



Wed, 18 Jun 1902 08:00:00 GMT  
 Problem with Smalltalk Application on WindowsNT 3.51

Quote:

> I am testing a custom smalltalk application (written for WindowsNT4.0)
> on a WindowsNT 3.51 machine. When I launch the app, I get this error
> message: "missing 1 in cwcswin"  I did not write the application and
> have been given the task of testing it for our WindowsNT 3.51 users.
> Has anybody ever seen this or heard of this error. The error causes
> the app to close right after launch. I have searched for an answer
> everywhere, including smalltalk support. Thanks in advance for your
> help.

I don't know much about other tools (such as VW..) but In VisualAge, there
is a 'walkback.log' file (usualy found in the app's directory) that
contains a detailed description of the problem.
It sounds like you are missing some file needed for the runtime.

Regards,

Eyal Kattan
--
 ******  A T T E N T I O N *********
The address for reply contains
AntiSpam. Please use the following
address when replying.


***********************************



Wed, 18 Jun 1902 08:00:00 GMT  
 Problem with Smalltalk Application on WindowsNT 3.51

Quote:

> I am testing a custom smalltalk application (written for WindowsNT4.0)
> on a WindowsNT 3.51 machine. When I launch the app, I get this error
> message: "missing 1 in cwcswin"  I did not write the application and
> have been given the task of testing it for our WindowsNT 3.51 users.
> Has anybody ever seen this or heard of this error. The error causes
> the app to close right after launch. I have searched for an answer
> everywhere, including smalltalk support. Thanks in advance for your
> help.

> Manuel Rodriguez-Perez
> Technical Services
> Florida Power and Light

Manuel:

cwcswin.cat is a message catalog file. It looks like your first problem is
that your don't have access to the message catalog that has the message
you need. Message catalogs are usually pointed to by the 'nlspath'
variable in the abt.ini file.

The second problem is that you may not be running the required level of
WIN/NT. I'm actually guessing here, but it appears that the piece of code
that is trying to put up the message (OsWidget class>>#checkVersion) isn't
finding Win32s 1.25 or higher. After putting up the message, it performs
System exit, which would explain why the image just goes away.

Just to wrap up, I found all this out by inspecting the result of
executing the following in the development environment:
(NlsMessageCatalog on: 'cwcswin.cat')
   loadLanguage: 'english'
   territory: 'us'
   characterSet: 'ansi-ascii'

...and then browsing references to the first element from the inspector.
That took me right to the method described above.

^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
Mike Silverstein, Lead Architect        voice: (919) 363-3946
SilverMark, Inc.                          fax: (919) 362-0772

Raleigh, NC                         http://www.silvermark.com



Wed, 18 Jun 1902 08:00:00 GMT  
 Problem with Smalltalk Application on WindowsNT 3.51

Quote:


> > I am testing a custom smalltalk application (written for WindowsNT4.0)
> > on a WindowsNT 3.51 machine. When I launch the app, I get this error
> > message: "missing 1 in cwcswin"  I did not write the application and
> > have been given the task of testing it for our WindowsNT 3.51 users.
> > Has anybody ever seen this or heard of this error. The error causes
> > the app to close right after launch. I have searched for an answer
> > everywhere, including smalltalk support. Thanks in advance for your
> > help.

> > Manuel Rodriguez-Perez
> > Technical Services
> > Florida Power and Light

> Manuel:

> cwcswin.cat is a message catalog file. It looks like your first problem is
> that your don't have access to the message catalog that has the message
> you need. Message catalogs are usually pointed to by the 'nlspath'
> variable in the abt.ini file.

> The second problem is that you may not be running the required level of
> WIN/NT. I'm actually guessing here, but it appears that the piece of code
> that is trying to put up the message (OsWidget class>>#checkVersion) isn't
> finding Win32s 1.25 or higher. After putting up the message, it performs
> System exit, which would explain why the image just goes away.

> Just to wrap up, I found all this out by inspecting the result of
> executing the following in the development environment:
> (NlsMessageCatalog on: 'cwcswin.cat')
>    loadLanguage: 'english'
>    territory: 'us'
>    characterSet: 'ansi-ascii'

> ...and then browsing references to the first element from the inspector.
> That took me right to the method described above.

Correction: 'abt.ini' in the development environment gets repackaged for
deployment as 'xxx.ini', where 'xxx' is the name of the executable.

^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
Mike Silverstein, Lead Architect        voice: (919) 363-3946
SilverMark, Inc.                          fax: (919) 362-0772

Raleigh, NC                         http://www.silvermark.com



Wed, 18 Jun 1902 08:00:00 GMT  
 
 [ 4 post ] 

 Relevant Pages 

1. Clarion 2 application on WinNT 3.51

2. Q: IBM Smalltalk 3.0 under WindowNT 3.51

3. CW2002 - Problem running on Citrix Winframe over NT 3.51

4. CW2003 - problem with NT 3.51

5. NT 3.51 problem

6. Timeslice problems with the good Clipper 5.2e and (Windoof NT 3.51) Citrix Winframe 1.7

7. Screen update problems in Windows NT 3.51

8. Pioneer problems with Windows NT 3.51

9. WIN NT 3.51 Scratch File opening problem

10. Problem with installing tcl 7.6 windows kit on Win NT 3.51

11. My labVIEW application is not working on an WindowsNT system when I have no administrator rights

12. apl character set under win nt 3.51 (stsc)

 

 
Powered by phpBB® Forum Software