special character codes on different platforms 
Author Message
 special character codes on different platforms

Hi World

I use special characters (especially german Umlaute) within text
labels, buttons and menues of my Parts in VisualAge 3.0a.
The problem is that the code scheme of special characters might be differen=
t on
different platforms. It is diferent on OS2 and WinNT.
If I start my application under OS2 everything is fine. The same
application shows diferent text labels under WinNT.
I can solve this problem by using the National Language support.
To do that I have to create an mpr-file
for my application and I have to type all labels with special characters
once for each platform.
Does someone know an easier way to get rid of that problem?

A simular problem occurs when I store Strings with special characters
into a database (DB2) and read them from another platform. Probably I
have to unify the strings whenever they are stored. Does VA supply
a proper solution for that problem ?

    Thanks John!



Mon, 20 Sep 1999 03:00:00 GMT  
 special character codes on different platforms

John,

Are you using different fonts for different platforms?  Each font
has a different set of characters and, apart from the standard alphabet
characters, the same character is not always represented by the same
code.

Tony Weddle
PMS Creative

Quote:

> Hi World

> I use special characters (especially german Umlaute) within text
> labels, buttons and menues of my Parts in VisualAge 3.0a.
> The problem is that the code scheme of special characters might be differen=
> t on
> different platforms. It is diferent on OS2 and WinNT.
> If I start my application under OS2 everything is fine. The same
> application shows diferent text labels under WinNT.
> I can solve this problem by using the National Language support.
> To do that I have to create an mpr-file
> for my application and I have to type all labels with special characters
> once for each platform.
> Does someone know an easier way to get rid of that problem?

> A simular problem occurs when I store Strings with special characters
> into a database (DB2) and read them from another platform. Probably I
> have to unify the strings whenever they are stored. Does VA supply
> a proper solution for that problem ?

>     Thanks John!




Tue, 21 Sep 1999 03:00:00 GMT  
 
 [ 2 post ] 

 Relevant Pages 

1. list-directed read statement works in different way on different platforms

2. Different screen resolutions on different platforms

3. Special Chars between platforms

4. menubar creation, visual appearance and platform special menus

5. Image converting for different platforms (VW 2.5.2)

6. EAI works (or doesn't work) differently under different platforms

7. verilog different behavior code and RTL code?

8. Perplexing problem on 2 different Alpha OpenVMS platforms

9. Source compatibility between different platforms

10. underflow under different platform

11. writing binary file for different platform

12. Conditional compilation for different platforms

 

 
Powered by phpBB® Forum Software