symbol table error ? 
Author Message
 symbol table error ?

greetings all;

i have compiled a 20000+ line bp7 program, the program gives an GPF
indicating that there is an error within an ExitProc (which is not
being called!).  When I try to Browse a local symbol of one unit (the
LocalExitProc procedure), the Browser finds that it is 'coupled' to the
LocalExitProc of another, unrelated unit.  Obviously, i have not exported
these procedures, as they are used in the exit chain mechanism of BP7.  
When i rename the two procedures to be unique, all is well, the program
runs, and the Browser correctly identifies the two exit procedures to be
unique.

THis behaviour is odd to say the least!  Increasing the stack size does
not help.  Is this an overflow/bug in the symbol table managment, or do I
have another more profound problem hiding in my code?

TIA
--
p. rowntree
Departement de chimie, Universite de Sherbrooke, Sherbrooke, Quebec,
Canada



Wed, 18 Jun 1902 08:00:00 GMT  
 
 [ 1 post ] 

 Relevant Pages 

1. Error Reading Symbol Table

2. HELP: "Error in Symbol File" message

3. "Lost OF TABLE-Symbols"

4. Symbol Table Overflow

5. Table repair utility error table not found

6. Euro currency symbol ...

7. strange symbols in tp for dos 7

8. math symbols please help me

9. Paradox picture symbols

10. Euro currency symbol ...

11. Debugging child process with TD, how to get symbol info for child program

12. Debugging child process with TD, how to get symbol info for child program

 

 
Powered by phpBB® Forum Software