bgi drivers 
Author Message
 bgi drivers

Hiya,

Here's something I find a little odd. I loaded BP7 onto my D: drive and when
I used InitGraph it couldn't locate my driver files no matter what I put in
the DriverPath. As soon as I copied the BGI directory to the root directory
of C: - InitGraph was fine. Now in fact I only have to put ' ' as the
DriverPath and it works fine. Anyone know what's going on here?

Robert Ellis



Wed, 18 Jun 1902 08:00:00 GMT  
 bgi drivers

Quote:

>Hiya,

>Here's something I find a little odd. I loaded BP7 onto my D: drive and when
>I used InitGraph it couldn't locate my driver files no matter what I put in
>the DriverPath.

Could you list the things you put there? Sure if you put the correct path
it works.

 As soon as I copied the BGI directory to the root directory

Quote:
>of C: - InitGraph was fine. Now in fact I only have to put ' ' as the
>DriverPath and it works fine. Anyone know what's going on here?

It works if you are in the root.

Osmo



Wed, 18 Jun 1902 08:00:00 GMT  
 bgi drivers
Hi Osmo,

Found the problem - I copied BP to D: from a cd I made prior to leaving
Canada and coming here to the U.K. When I copied the BP directory from the
cd to d:, all the files had the read-only attribute set. Once I cleared the
read only attribute from the .bgi files, BP could find the drivers fine. Of
course, why the read-only bgi files copied to the root of c: resulted in my
program running is not clear to me. Thanks for your reply. BTW - is this a
common problem for files copied to a CD - when you copy them to another
machine from the cd are they then assigned read only by default or did I
miss a setting in the software when I burned the cd?

Quote:


> >Hiya,

> >Here's something I find a little odd. I loaded BP7 onto my D: drive and
when
> >I used InitGraph it couldn't locate my driver files no matter what I put
in
> >the DriverPath.

> Could you list the things you put there? Sure if you put the correct path
> it works.

>  As soon as I copied the BGI directory to the root directory
> >of C: - InitGraph was fine. Now in fact I only have to put ' ' as the
> >DriverPath and it works fine. Anyone know what's going on here?

> It works if you are in the root.

> Osmo



Wed, 18 Jun 1902 08:00:00 GMT  
 bgi drivers
All files on the CD are read-only - it's a read-only medium and you
cannot specify anything else when burning it.  The RO attribute follows
with the CD-HD copy process.
Quote:

> Hi Osmo,

> Found the problem - I copied BP to D: from a cd I made prior to leaving
> Canada and coming here to the U.K. When I copied the BP directory from the
> cd to d:, all the files had the read-only attribute set. Once I cleared the
> read only attribute from the .bgi files, BP could find the drivers fine. Of
> course, why the read-only bgi files copied to the root of c: resulted in my
> program running is not clear to me. Thanks for your reply. BTW - is this a
> common problem for files copied to a CD - when you copy them to another
> machine from the cd are they then assigned read only by default or did I
> miss a setting in the software when I burned the cd?




> > >Hiya,

> > >Here's something I find a little odd. I loaded BP7 onto my D: drive and
> when
> > >I used InitGraph it couldn't locate my driver files no matter what I put
> in
> > >the DriverPath.

> > Could you list the things you put there? Sure if you put the correct path
> > it works.

> >  As soon as I copied the BGI directory to the root directory
> > >of C: - InitGraph was fine. Now in fact I only have to put ' ' as the
> > >DriverPath and it works fine. Anyone know what's going on here?

> > It works if you are in the root.

> > Osmo



Wed, 18 Jun 1902 08:00:00 GMT  
 bgi drivers


Quote:

>All files on the CD are read-only - it's a read-only medium and you
>cannot specify anything else when burning it.  The RO attribute follows
>with the CD-HD copy process.

So, though it's too late for you now, one should first scan the whole
pre-backup area and record all the file attributes (and anything else;
it makes a nice index) into a file;
        HUNT \ s p q > \filedata.dat
should do (probably misrecording \filedata.dat's details); and let that
go on the CD.  After restoring the files off CD, one then has the
information needed to restore the attributes.

--

 Web <URL: http://www.merlyn.demon.co.uk/> - FAQqish topics, acronyms & links.
 PAS, EXE in <URL: http://www.merlyn.demon.co.uk/programs/> - see 00index.txt.
 Do not Mail News to me.    Before a reply, quote with ">" or "> " (SoRFC1036)



Wed, 18 Jun 1902 08:00:00 GMT  
 bgi drivers


(Moved Tom's reply below the text to which it refers)

Quote:

>> Hi Osmo,

>> Found the problem - I copied BP to D: from a cd I made prior to leaving
>> Canada and coming here to the U.K. When I copied the BP directory from the
>> cd to d:, all the files had the read-only attribute set. Once I cleared the
>> read only attribute from the .bgi files, BP could find the drivers fine. Of
>> course, why the read-only bgi files copied to the root of c: resulted in my
>> program running is not clear to me. Thanks for your reply. BTW - is this a
>> common problem for files copied to a CD - when you copy them to another
>> machine from the cd are they then assigned read only by default or did I
>> miss a setting in the software when I burned the cd?
>All files on the CD are read-only - it's a read-only medium and you
>cannot specify anything else when burning it.  The RO attribute follows
>with the CD-HD copy process.

But if you copy a read-only file using the Copy command in a DOS
shell, the read-only attribute does not get copied with it. So the BGI
file in the root of c: would be read/write and the program runs.

FP



Wed, 18 Jun 1902 08:00:00 GMT  
 
 [ 6 post ] 

 Relevant Pages 

1. BGI drivers

2. Installing User BGI driver

3. how to write my own BGI driver?

4. Need BGI driver for HP Deskjet

5. Embedding a BGI Driver

6. Initializing an S3 BGI Driver in a unit

7. NT and VESA 800x600 BGI Driver

8. BGI driver & mouse

9. bgi driver for ATI agp graphics card

10. True-color BGI-driver for Borland Pascal 7.0 ?

11. 800x600x16 VGA Mode - Is there a BGI Driver

12. BGI drivers

 

 
Powered by phpBB® Forum Software