Problems with System.Free in MacOberon4.02 
Author Message
 Problems with System.Free in MacOberon4.02

I could well be doing something wrong but I have
been having trouble with System.Free in MacOberon 4.02.

Normally I would just click MM'ML on a command to unload
the module BUT I'm a newbie and forgot the inter-click and
decided to use System.Free.

I created a new module with a unique name which naturally
no-one else could import from (as I just created it).
I made some changes and recompiled and tried to unload it
by System.Free NewModule
and initially it worked.
Then at some point in time it stopped working.
I restarted MacOberon and loaded the Module and tried
System.Free NewModule and again it would continously fail.
I checked the manual and it said to check that it wasn't in use
by another module BUT I don't know how it could be as I have just
created it.

I tried System.Free on another module (which I may have not loaded),
just to try something different and I went into an
infinite loop. Very impressive :-(
I restarted MacOberon and tried again, with no problem for this other
module.
Something seems funny.

For the moment I shall stick to inter-clicking ML on command execution.
That seems to work with no problems (touch wood).

Anyone else had this problem ??

--tim
--
     --------------------------------------------------------

 / Computer Science Department, Monash Uni (Clayton), Australia \  
|________________________________________________________________|



Wed, 22 May 1996 19:25:43 GMT  
 
 [ 1 post ] 

 Relevant Pages 

1. CFP Generators and Components (GCSE/SAIG'02) (Pittsburgh, 10/02)

2. CA-Clipper 5.2E 02/02

3. CFP Generators and Components (GCSE/SAIG'02) (Pittsburgh, 10/02)

4. Ada News Summaries - Week Ending - 96-02-02.txt [1/1]

5. rmcobol 7.00.02 Error 47,02

6. NT & VA4.02 problems

7. CW55.01, 02 CtlOLE.TPW Problem

8. PR-Tracker v2.02 -- Tracks problem reports, bugs, defects

9. HELP! Packaging problem with 4.02+

10. FREE ** IBM SYSTEM 36 ** FREE

11. Image Crash in VA4.02

12. 02:RESULT: comp.os.tpf moderated passes 210:9

 

 
Powered by phpBB® Forum Software