oberon for linux 2.3.6h 
Author Message
 oberon for linux 2.3.6h

hi,

I just reinstalled oberon for linux;.. it seems to be a new version
(2.3.6h)...

I'm trying to recompile my old files, but it seems like the compiler can't
handle Receivers anymore?? It yealds an error: "Identifier expected"

for example:

PROCEDURE (l : List) Create();

won't compile anymore!

Is this a compiler option??
If not, is there any way to get the old version back??

any help appreciated...

Hans



Mon, 08 Sep 2003 02:49:15 GMT  
 oberon for linux 2.3.6h
[Posted and mailed]



Quote:

> hi,

> I just reinstalled oberon for linux;.. it seems to be a new version
> (2.3.6h)...

> I'm trying to recompile my old files, but it seems like the compiler can't
> handle Receivers anymore?? It yealds an error: "Identifier expected"

> for example:

> PROCEDURE (l : List) Create();

> won't compile anymore!

> Is this a compiler option??
> If not, is there any way to get the old version back??

> any help appreciated...

The new release uses the compiler from Native Oberon. This compiler
contains some extensions to the oberon laguage which are decribed in
the Oberon Companion book (contained in the system). If you want to
compile programs which use the Oberon2 syntax for type bound procedures
(methods) you have to use the compiler switch \2.

-- Guenter



Mon, 08 Sep 2003 05:48:34 GMT  
 
 [ 2 post ] 

 Relevant Pages 

1. Clean your PC properly ( q 6h)

2. Question About LF95 v5.6h executables

3. ANNOUNCE: TkPixmap3.6h

4. Sr. Lotus Notes Developer - Dallas, TX 7/22/98 6:00:11 PM

5. Questions about Gadgets programming in Linux Native Oberon 2.3.7

6. Oberon and Linux

7. oberon interface to Linux c.

8. Native Oberon System-3 on Linux GGI

9. networking in linux native oberon

10. Keyboard Halt in Oberon for Linux

11. Symbol files in Oberon for Linux

12. Backspace and cursos keys not working in oberon for linux

 

 
Powered by phpBB® Forum Software