MSWLogo 6.4h - setfont command fails - WinXP Pro 
Author Message
 MSWLogo 6.4h - setfont command fails - WinXP Pro

Hi,    

        I'd guess this one is for George Mills, but I was wondering if
        others had experienced the same or could check it out.

        Environment:
                Clean install of Win XP Pro, 1.3 MHz AMD Athlon with 512 MB.
                Using MSWLogo 6.4h.
                Testing code that worked under Win98SE/MSWLogo 6.4h.
                300+ fonts installed.

        Noticed:
                o       setlabelfont works from MSWLogo Screen SET command menu.
                o       setlabelfont fails for SOME fonts from the Commander's
                        command line or from within code.

        Experimented:
                o       setlabelfont worked for the ones I tried that were
                        suggested in the list of fonts that follows the error
                        message (see below)
                o       Fonts not in the list didn't work.  I tried 8 or 9.
                o       Could not find a correlation between which fonts
                        worked and which didn't based upon:
                                Font type - TrueType (.ttf),
                                                 OpenType (.ttf),
                                                 other (.FON)
                                Fonts that came with WinXP or were installed later.
                                Font pitch - Fixed vs. Variable.
                o       Rebooting had no effect.  Cursing had no effect.
                o       Changed code to use one of the fonts that would
                        *setlablefont* as a workaround.

        +++++++++++  *** Commander window ***  +++++++++++

        -- manual operation,  ** Commander input,       == Commander output

        -- use Set menu item to set font to Archietct --

        ** Label [Font set from Set menu]

        == "Font set from Set menu"    appears correctly on screen.

        ** show labelfont

        == [[Architect] -20 0 0 400 0 0 0 0 3 2 1 34]

        ** setlabelfont [[Architect] -20 0 0 400 0 0 0 0 3 2 1 34]

        == Sorry, Architect Font does not exist, choose ...
        ==
        ==
        == [System]
        ==
        == [8514oem]
        ==
                 List collapsed to save space

        == [Fixedsys] [Terminal] [Roman] [Script] [Modern] [WST_Czec]
        == [WST_Engl] [WST_Fren] [WST_Germ] [WST_Ital] [WST_Span]
        == [WST_Swed] [Courier] [MS Serif] [MS Sans Serif] [Small Fonts]
        == [CTOS] CTOS8034] [CTOSW] [Lucida Sans B] [Lucida Sans B1]
        == [Lucida Sans B2] [Symbol B] [8514fix] [Marlett] [Arial]
        == [Arial CE] [Arial CYR] [Arial Greek] [Arial TUR] [Arial Baltic]
        == [Courier New] [Courier New CE] [Courier New CYR]
        == [Courier New Greek] [Courier New TUR] [Courier New Baltic]
        == [Lucida Console] [Lucida Sans Unicode] [Times New Roman]
        == [Times New Roman CE] [Times New Roman CYR]
        == [Times New Roman Greek] [Times New Roman TUR]
        == [Times New Roman Baltic] [Wingdings] [Symbol] [Verdana]
        == [Arial Black] [Comic Sans MS] [Impact] [Georgia]
        == [Franklin Gothic Medium] [Palatino Linotype] [Tahoma]
        == [Trebuchet MS] [Webdings] [Estrangelo Edessa] [Gautami]
        == [Latha] [Mangal] [MV Boli] [Raavi]

Thanks,

David



Thu, 13 May 2004 22:59:43 GMT  
 
 [ 1 post ] 

 Relevant Pages 

1. MSWLogo 6.4h - setfont command fails - WinXP Pro

2. LOGO-L> MSWLogo 6.4h is available

3. BLT2.4h graph element order has been reversed.

4. BLT 2.4h graph widget bug report

5. setfont command in Terrapin Logo

6. anyone runing FD on winXP (pro)?

7. AdaBrowse & WinXP Pro

8. wxPython w/ IDLE under WinXP Pro

9. Slow "recording" on winXP Command

10. command line (WinXP)

11. Inconsistent file command behaviour on WinXP

12. How to write accent in WinXP Command Prompt ?

 

 
Powered by phpBB® Forum Software