Different behaviour - UCBLOGO, MSW-LOGO, TKTS-LOGO 
Author Message
 Different behaviour - UCBLOGO, MSW-LOGO, TKTS-LOGO

repcount should be restored after calling a procedure. It
looks like UCBLogo isn't restoring it, but is resetting it
back to -1.
Brian?

Jamie

Quote:
> -----Original Message-----

> Sent: Saturday, February 23, 2002 12:20 PM

> Subject: [LogoForum] Different behaviour - UCBLOGO,
MSW-LOGO,
> TKTS-LOGO

> The following procedure produces different outputs when
run in
> UCBLOGO, MSWLOGO and TKTSLOGO.

> to before.after :n
> if equalp :n 0 [stop]
> repeat 2 [print se "before repcount before.after :n-1
print se "after
> repcount]
> end

> before.after 2

> -----------------------------
> MSW-LOGO 6.4h
> before 1
> before 1
> after 1
> before 2
> after 2
> after 1
> before 2
> before 1
> after 1
> before 2
> after 2
> after 2
> --------------------------------
> TKTS-LOGO 1.03
> before 1
> before 1
> after 1
> before 2
> after 2
> after 1
> before 2
> before 1
> after 1
> before 2
> after 2
> after 2
> -----------------------------------
> UCBLOGO 5.1
> before 1
> before 1
> after 1
> before 2
> after 2
> after -1
> before 2
> before 1
> after 1
> before 2
> after 2
> after -1

> Guido Gay

> To unsubscribe from this group, send an email to:

> LogoForum messages are archived at:
> http://www.*-*-*.com/

> Your use of Yahoo! Groups is subject to
> http://www.*-*-*.com/

To unsubscribe from this group, send an email to:

LogoForum messages are archived at:
http://www.*-*-*.com/

Your use of Yahoo! Groups is subject to http://www.*-*-*.com/



Fri, 13 Aug 2004 12:30:57 GMT  
 Different behaviour - UCBLOGO, MSW-LOGO, TKTS-LOGO
The following procedure produces different outputs when run in
UCBLOGO, MSWLOGO and TKTSLOGO.

to before.after :n
if equalp :n 0 [stop]
repeat 2 [print se "before repcount before.after :n-1 print se "after
repcount]
end

before.after 2

-----------------------------
MSW-LOGO 6.4h
before 1
before 1
after 1
before 2
after 2
after 1
before 2
before 1
after 1
before 2
after 2
after 2
--------------------------------
TKTS-LOGO 1.03
before 1
before 1
after 1
before 2
after 2
after 1
before 2
before 1
after 1
before 2
after 2
after 2
-----------------------------------
UCBLOGO 5.1
before 1
before 1
after 1
before 2
after 2
after -1
before 2
before 1
after 1
before 2
after 2
after -1

Guido Gay

To unsubscribe from this group, send an email to:

LogoForum messages are archived at:
http://groups.yahoo.com/group/LogoForum

Your use of Yahoo! Groups is subject to http://docs.yahoo.com/info/terms/



Thu, 12 Aug 2004 10:56:51 GMT  
 Different behaviour - UCBLOGO, MSW-LOGO, TKTS-LOGO

Quote:

>repcount should be restored after calling a procedure. It
>looks like UCBLogo isn't restoring it, but is resetting it
>back to -1.
>Brian?

Yup.  Will be fixed in 5.2.  (Hey, George, how come it works in
MSWLogo?  Did you fix this eval bug and not tell me??)


Sun, 15 Aug 2004 03:10:21 GMT  
 
 [ 3 post ] 

 Relevant Pages 

1. Different behaviour - UCBLOGO, MSW-LOGO, TKTS-LOGO

2. LOGO-L> Apple logo/MSW Logo

3. Procedures names in UCBLogo, MSWLogo, TKTSLogo

4. LOGO-L> TYPE in MSWLogo vs UCBLogo

5. LOGO-L> Re: MSWLogo-UCBLogo

6. LOGO-L> PC-LOGO syntax in MSWLogo

7. LOGO-L> Re: MSW LOGO hardcopy

8. LOGO-L> msw logo: turtling

9. LOGO-L> RE: MSW Logo and Interfacing

10. LOGO-L> MSW-logo and values

11. LOGO-L> Re: MSW Logo

12. LOGO-L> Re: MSW LOGO

 

 
Powered by phpBB® Forum Software