Problem with MS Access variant data 
Author Message
 Problem with MS Access variant data

Hi,

I'm having a problem retrieving data from a MS Access table. The DB
Variant to Data function is continuously giving an error. I am using
the DB data select function to extract the data from the database. I'm
attempting to read both text and number data; when attempting to read
the text data the variant output is:

<i>OLE Variant

<i>Variant Type->
<i>VT_BSTR
<i>Value-></i>

I also receive an error. Something like "incorrect input". The value
in the variant seems to be correct, why am I receiving an error?

Thanks in advance.



Sat, 25 Jun 2005 05:00:35 GMT  
 Problem with MS Access variant data
Did you get an error code or an error message?  This would help us
look for hits on the web. A little example would also help.

I found the following link that might be what you are looking for:

http://exchange.ni.com/servlet/ProcessRequest?RHIVEID=101&RNAME=ViewQ...



Sun, 26 Jun 2005 00:59:43 GMT  
 Problem with MS Access variant data
A little more information might help in solving this problem.  What
are you wiring to the type selector?  Are you receiving this error at
run-time?  What is the error number you are receiving?  Do you get
this error when you cast variants to numerics?  Please repsond and I
will see if I can help you out.


Sun, 26 Jun 2005 01:03:17 GMT  
 Problem with MS Access variant data
Thanks,

I did check out that link. It <i>should</i> work; it's doing exactly
what I'm trying to do, but I'm not having success retrieving data with
that vi either. I did respond to another fellow who's trying to help
me out. I described the error in detail in that message.



Sun, 26 Jun 2005 01:35:52 GMT  
 Problem with MS Access variant data
Hi,

Sure, I can provide some more information. I am wiring a numeric
constant "0" in long integer representation to the <i>DB Variant to
Data</i> function. The data I'm trying to get out of Access is long
integer data. The error I'm receiving from labview (I have a simple
error handler wired at the end) is:

Error 1 occured at Incorrect function in <i>Database Fetch.vi</i>

Possible Reasons

LABVIEW: An Input Parameter is invalid

or

NI-488: Command requires GPIB controller to be controller in charge

I don't have a GPIB card in my machine. In this particular case I was
trying to cast the variant to a numeric. I'm not sure if the error
occured in real-time; I don't know what that means. I can tell you
that I used the VI progress monitor (light bulb) and the error is
occuring at the <i>DB Variant to Data</i> function.

This is the output to the variant indicator:

OLE Variant

Variant Type ->VT_I4
Value ->1



Sun, 26 Jun 2005 01:31:49 GMT  
 
 [ 5 post ] 

 Relevant Pages 

1. Problems with ODBC MS Access Data source

2. Problem with variant data

3. Data conversion from a Flexfile II to MS Access

4. Writing data to MS Access

5. how to bind data to front panel object from ms-access

6. Writing data to MS Access

7. Retrieving data from an MS Access Database

8. MS Access Data Bases

9. Problem with ODBC connect to MS Access

10. Why loop variants are integers (MS/BM)

11. Problem reading MS Access file with C55PE

12. Decode variant data w/o using 'Variant To Data' function.

 

 
Powered by phpBB® Forum Software