I am using a timed while loop and am unable to get the loop... 
Author Message
 I am using a timed while loop and am unable to get the loop...

I am using a timed while loop and am unable to get the loop to run at
a speed of less than 1ms (I am currently using the Wait(ms) function).
How can I get a faster response?

I am trying to create a virtual engine within a timed while loop and
am unable to get the loop to run at a speed of less than 1ms (I am
currently using the Wait(ms) function).  This does not however allow
realistic engine speeds.  How can I overcome this?   I have access to
a PCI-MIO-16E-4 board.



Sun, 19 Sep 2004 19:19:49 GMT  
 I am using a timed while loop and am unable to get the loop...

Quote:

> I am using a timed while loop and am unable to get the loop to run at
> a speed of less than 1ms (I am currently using the Wait(ms) function).
> How can I get a faster response?

> I am trying to create a virtual engine within a timed while loop and
> am unable to get the loop to run at a speed of less than 1ms (I am
> currently using the Wait(ms) function).  This does not however allow
> realistic engine speeds.  How can I overcome this?   I have access to
> a PCI-MIO-16E-4 board.

Andy,

Unless you use a real time platform, getting extactly 1 ms loop rate
(or even less) is impossible. It starts getting troublesome at about
0.1 Hz for standard operating systems.

I'd tackle your problem with "if i mod 10 == 0 then sleep 1 ms". Of
course this is jerky by design.

HTH,

Johannes Nie?



Sun, 19 Sep 2004 22:31:43 GMT  
 I am using a timed while loop and am unable to get the loop...
If you need fast, reliable loop rates, labview Real Time is definitely
the way to go.  You can find more information on this product at the
following webpage: http://sine.ni.com/apps/we/nioc.vp?cid=3304&lang=US


Tue, 21 Sep 2004 03:03:55 GMT  
 
 [ 3 post ] 

 Relevant Pages 

1. using while loops within while loops?

2. Troubles using while loops and case loops

3. I am having trouble reading a time stamp on a video using OCR

4. I am not deaf, but am I mute?

5. I am unable to register my template!

6. Urgent!!Oracle9i:using ODBC, I am noy able to link to my database tables using Access

7. While Loop Unable To Be Compiled

8. unable to read (i+1) in do loop

9. Into what am I getting?

10. Why am I getting bind errors?

11. I am getting THISTHREADACTIVE error (lots of them)

12. I Am Getting Fed Up With Clarion

 

 
Powered by phpBB® Forum Software