Receive error-1 at TCP/IP read - GPIB controller must be controller in charge 
Author Message
 Receive error-1 at TCP/IP read - GPIB controller must be controller in charge

I have a stripped down version of Talk Module from the LV TCP/IP
examples. All it does is execute one TCP/IP read of 512 bytes and
reset the output error to no error if a timeout or close connection
error occurs. I placed it in the main loop of my program so it
executes one time each loop but I receive an Error 1 "GPIB controller
must be controller in charge" when it runs. I then stop the program
and get that same error from a different source before it exits. I
know it works because I can set it up in a separate VI and it works
fine. The program is controlling a GPIB power supply and a VXI
chassis. Any ideas what could be causing the error? Thanks.

Jason



Mon, 20 Dec 2004 05:36:14 GMT  
 Receive error-1 at TCP/IP read - GPIB controller must be controller in charge
error one hs two meanings, depending on the context. in this case it
is likely that the meaning is "invalid input parameter". have you
connected all of the inputs?, and have you opened the connection
first?. also, make sure you close the connection once you are done
withit. Otherwise, you may have problems with a port still being
inuse.

Hope this helps,

Matt



Tue, 21 Dec 2004 16:28:34 GMT  
 Receive error-1 at TCP/IP read - GPIB controller must be controller in charge
All the inputs are wired correctly and the connection is opened first.
I am using hyperterminal on another computer to check out the
connection. Sometimes after running the close connection VI,
hyperterminal says the connection is still open. When the VI stops
running, the connection is always lost and when the VI runs again, it
seems to have no problem opening the connection on the same port.
Thanks for the advice, I will check into it.

Jason



Fri, 24 Dec 2004 21:18:38 GMT  
 Receive error-1 at TCP/IP read - GPIB controller must be controller in charge
I have had this problem myself. I cant remember exactly what caused
it, but i think i was trying to open two connections on the same local
port.


Fri, 24 Dec 2004 21:51:21 GMT  
 
 [ 4 post ] 

 Relevant Pages 

1. Labview error GPIB controller not adressed correctly

2. Eurotherm Controller-2416: reading error

3. More than 10 GPIB-ENET controllers and VISA

4. GPIB-ENET Controller

5. NI GPIB Controller Dealer in USA?

6. sbus and scsi gpib controllers

7. external GPIB-USB Controller with Windows2000

8. Multiple GPIB controllers?

9. fortran tcp/ip receive problem

10. TCP/IP error 503 in CW5=ok in CW5.5b the error

11. Read FDD sector via DMA & Floppy Controller

12. Sporadic GPIB Read Error 6, Generic File I/O Error

 

 
Powered by phpBB® Forum Software