Problem with Matlab script node in LabVIEW 6.1 
Author Message
 Problem with Matlab script node in LabVIEW 6.1

I have some data stored in a Matlab mat file that I want to pull into
labview, so I used a script window and called Matlab's load function.
At this point I can transfer any of the existing data over to LabVIEW.
Unfortunately, the data is not exactly the way I want it, so I
reordered some arrays into new variables and passed those out.  Here
is where the problem occurs.  Upon first run, none of the reordered
data comes out and the computer beeps, but there is no error returned
from the Matlab script node.  If I run it a second time, it works
fine.
I have done a work-around where I have saved a new mat-file with the
data formatted how I want it, but I shouldn't have to do this.
This problem has shown up on both computers I have tested it on.
By the way, I am using MATLAB Version 6.1.0.450 (R12.1) on PCWIN.


Tue, 23 Nov 2004 22:11:31 GMT  
 Problem with Matlab script node in LabVIEW 6.1
Mattkav,

There are some issues with LabVIEW and MATLAB 6.1. Please refer to <a
href="http://digital.ni.com/public.nsf/3efedde4322fef19862567740067f3cc/ce3...">KnowledgeBase
2C1AH6DM: LabVIEW Does Not Interface Properly with MATLAB 6.1</a> for
more information and a DLL patch.

Randy Hoskin
Applications Engineer
National Instruments
http://www.ni.com/ask



Fri, 26 Nov 2004 20:37:14 GMT  
 Problem with Matlab script node in LabVIEW 6.1
Hi Randy
After clik on the link you gave I got:

Error
You are not authorized to view this document

What to do?
regards
Pawel



Tue, 22 Mar 2005 19:01:12 GMT  
 
 [ 3 post ] 

 Relevant Pages 

1. I can't find the MATLAB script node in labview

2. Integer and a string arrays to LabVIEW from Matlab script node

3. Upgrading to MATLAB 6.1 breaks LabView interface

4. LabView 6.1 vs MATLAB rel.13

5. LabView 6.1 formula node issue with negative exponent

6. Problems with IMAQ Vision after upgrading from Labview 6i to Labview 6.1

7. MATLAB Script Nodes and concurrency.

8. LabVIEW 6.1 problem with datasockets server starting

9. Compatibility problems between labview 4.0 and 6.1

10. File permission problem with Labview 6.1.

11. LabVIEW 6.1 problem with datasockets server starting

12. Labview 6.1 problems with VISA when running application executable

 

 
Powered by phpBB® Forum Software