LabView grabs all available serial ports 
Author Message
 LabView grabs all available serial ports

I'm using a VI that communicates via COM1and the serial VIs. Within
this VI I'm calling an EXE-program that communicates to another device
via COM2. But every time the EXE programs starts I get the message
that COM2 is occupied. If I start it without the VI then the program
can communicate. It seems that labview grabs all available ports even
if only one port is used in a VI. Does anybody know a solution?


Mon, 07 Feb 2005 15:17:04 GMT  
 LabView grabs all available serial ports
Are you using the older serial VIs or the new VISA serial VIs? If you
are using the older ones, then you may want to try out the newer VISA
based VIs. They probably won't suffer from the same problem.

Pete



Mon, 07 Feb 2005 18:06:13 GMT  
 LabView grabs all available serial ports
CK, you may want to do this.  I wrote a VI (using the VISA serial VIs)
which accesses both serial ports (COM1 and COM2) and it worked just
fine.  I did not receive any errors from either line of communication.
I was successfully able to write and read from both ports in the same
VI.


Tue, 08 Feb 2005 07:41:12 GMT  
 
 [ 3 post ] 

 Relevant Pages 

1. Problems with Labview 6i and serial port/visa

2. Is labview effective in handling synchronous serial port...

3. I having trouble using a serial i/o port with LabVIEW

4. Is labview effective in handling synchronous serial port...

5. address / irq of serial ports (labview 4.0 / windows 98)

6. serial port in labview

7. Using serial Ports in LabVIEW

8. Help: Serial Port+NT4+LabVIEW

9. How to open Serial Port in LABVIEW (mac)?

10. LabView and Serial-Ports under NT4.0

11. Labview, serial port, PPP

 

 
Powered by phpBB® Forum Software