error in Print Report.vi 
Author Message
 error in Print Report.vi

I get "Unknown Error in Print Report.vi", error code -2147352567 when
I run Text Report Example.vi in labview 6.1. My own code that ran OK
in LabVIEW 6.0.2 also produces this same result in V6.1. I have not
changed printers. Help.


Sun, 15 Aug 2004 05:57:08 GMT  
 error in Print Report.vi
Hi.
I don't have exact solution for your problem, but it is very familiar
to what I experienced.
I install 6.1 and Report Generation toolkit included with new package.
I had all my programs written in 6.0.2 with Report Generation from
version 1.0.
Almost every other VI from Report Generation did not work after I
recompiled my VI into Labview 6.1. I spent several days trying to
understand what is going on, made several calls to NI tech support,
but nobody could help me. Finally I found solution:
Uninstall New Report Generation toolkit Version 1.0a included into
latest package of Labview 6.1 and install the very first version (I
have it distributed as separate CD).
After such maneuver everything works fine.

I had another problem with this tool and especially Print report.vi:
I have PDS package, and Print report.vi works excellent on my computer
printing Standard Report. However when I create stand-alone
application and distribute it together with run-time engine on user
computers, it gives me error and I can only print creating Excel or
Word type of report.

So, that is my experience. I think NI still has several bugs to work
on. And if you find any other solutions, please let me know.
Good luck.



Sun, 15 Aug 2004 21:55:10 GMT  
 error in Print Report.vi
Sometimes the NI reports ActiveX objects get a little flaky when you
install one version of NI Reports over another.  First see if the NI
Reports type library is properly registered with the system.  Drop an
activeX refnum, and see if NI Reports is in the list of classes.  If
it is, you might first try manually relinking the NI Reports VIs to
the ActiveX class.  Otherwise:

1)Erase the NI Reports folder from the National Instruments\shared
directory.

2)Open the registry editor and erase the NI Reports key under
HKEY_LOCAL_MACHINE\Software\National Instruments.

3)Reinstall the newest version of the LabVIEW Runtime Engine, this
will also reinstall the newest version of NI Reports.



Mon, 16 Aug 2004 02:17:24 GMT  
 error in Print Report.vi
Tried 1-3 to no effect. NI Reports is in the list of classes. How do I
"...manually relink..."?


Mon, 16 Aug 2004 03:18:30 GMT  
 error in Print Report.vi
Before you do that, check the size of the margins.  Some printers have
a minimum margin size.  If you try to set the margins too small, you
might get this error.

If its not that, use highlight execution and step modes to find out
exactly where the error is coming from.  Open up the problem VI and
first try doing a force recompile, press CTRL+ALT+Run Arrow.  See if
it makes any difference.  The error must be coming from either an
automation open, a property or invoke node. If its an open, right
click on the associated refnum and rechoose the activex class for it.
If its a property or invoke node, try replacing it with a new one.



Mon, 16 Aug 2004 05:56:33 GMT  
 error in Print Report.vi
I already checked into the margins but to no effect.

The "unknown error" comes from the "Invoke Method:Printout" within
"Print Report.vi". I deleted and replaced the Invoke but got the same
result. CTRL+ALT+Run Arrow yielded no error, but still no printout.

If I build an executable with the Application Builder, the executable
prints properly. The .vi's running within LabVIEW 6.1 will not.



Tue, 17 Aug 2004 00:00:07 GMT  
 error in Print Report.vi
So the Text Report Example VI in 6.1 doesn't work in the development
environment,but if you build a 6.1 executable and run it on the same
machine it works?!!  That is bizarre.  Do you still have 6.0 installed
on that machine? Does it work there?


Tue, 17 Aug 2004 04:03:04 GMT  
 error in Print Report.vi
That's correct. Both Text Report Example.vi and my .vi run when built
into executables, but they both fail in the 6.1 development
environment. They both fail at "Print Report.vi".

I uninstalled 6.0 right after I installed 6.1, but before I found this
problem. :( Then I uninstalled and re-installed 6.1 a few times trying
to solve this problem. I'd rather not re-install 6.0; I've wasted
enough time on this already. Any other ideas would be appreciated.



Tue, 17 Aug 2004 04:30:36 GMT  
 error in Print Report.vi
Hi.
I followed your letters exchange from the very beginning. As I
described it in the first reply on your question, I had the same
problem. And now I am very sure that you have exactly the same story.
So, try un-install report generation toolset through the Control
panel>>Add/remove software.
Then, install report generation toolkit from Labview 6.0.  In my case
it works just perfect without loosing functionality.

Good luck.

Peter.



Tue, 17 Aug 2004 05:09:01 GMT  
 error in Print Report.vi
I don't have a "report generation toolset" appearing in the Control
panel>>Add/remove software.


Fri, 20 Aug 2004 21:30:58 GMT  
 error in Print Report.vi
Sorry, I had not checked the exact name. It's called NI Labview Report
Generation Toolkit for Microsoft office.
Do you have one in Add/Remove programs  in Conrol Panel?
If not it is really strange and in this case I would contact NI and
ask them for tech support. May be tell them about my experience and
you can even mention request# 399786.
Good luck,

Peter.



Fri, 20 Aug 2004 22:10:57 GMT  
 error in Print Report.vi

Quote:
> Sorry, I had not checked the exact name. It's called NI Labview Report
> Generation Toolkit for Microsoft office.
> Do you have one in Add/Remove programs  in Conrol Panel?
> If not it is really strange and in this case I would contact NI and
> ask them for tech support. May be tell them about my experience and
> you can even mention request# 399786.
> Good luck,

> Peter.

Problem on execution of  "Test Report Example.vi" or any program using
"Easy Text Report.vi".
Program tested on Windows 98 SE with both labview 6.0.2 and 6.1
installed, base NIReport VI.

Under LabView 6.1 and selecting Standard report, error  -1073741819

Solution found with the help from NI support.

The solution is quite strange but it works.
Load the example and by  Browse > Show VI Hierarchy  select the "Font
Style.VI".
Go to diagram and change the leftmost property node "Report - Text Font"
to any other and then go back to "Text Font".
 Save the VI.

After this on my computer I get  another error  -2147352567 on "Print
Report VI".
After some investigation and debugging with no results, I tried to do
the same thing on any property nodes in all sub VI (excluded the HTLM
sub VI).
I do not know exactly which VI is wrong , but at the end of this
operation the example was OK and so also any other test made with Text
Report.

Bugs report on NIReport Toolset for office from NI Developer Suite 2002
(February)

The word, Exel and HTML seems working fine, but again the standard
report generate error.
After many test and compare with the base version I find the error on
the Tables.Vi and again in the Font Style.VI.

In ToolSet Tables.VI there are errors  in closing  some automation
reference number (not easy to explain). I suggest to replace this VI
with the one from the base version. The tool set rename the base library
version to ..\vi.lib\utility\NIReport.bkp at installation.

In Font Style.VI at the exit of the program there is an Automation Open
instead of a Close operation. Replace it and save.

--
Posted via Mailgate.ORG Server - http://www.Mailgate.ORG



Tue, 24 Aug 2004 15:06:45 GMT  
 error in Print Report.vi
These instructions partially solved a problem with similar symptoms on
my Windows 2000 PC running LabVIEW PDS 6.1.  I also had to correct the
Font Style.vi as per NI document 2IDB7OLD (replace an Automation Open
function with an Automation Close) to completely solve the problem;
before the last change, I was getting a 3005 error from the samples.


Fri, 19 Nov 2004 23:52:56 GMT  
 
 [ 13 post ] 

 Relevant Pages 

1. printing with print report.vi

2. Error in Append Image to Report.vi

3. Vi Name string for NI print panel vi - how to get dynamically for vi the print panel vi is in.

4. DEVOUT() Error when printing long reports - SOLUTION FOUND?

5. error according printing html report

6. ni reports: issue with Set Report Font.vi

7. Why does LabVIEW report a error when printing?

8. Print waveform chart by print panel.vi

9. Printing Report Writer report to a file?

10. Crystal Reports New Print Job Within a Print Job

11. Printing a report and using the print dialog for it

12. Pre-setting Print jobAttributes (printing a ReportWriter report)

 

 
Powered by phpBB® Forum Software