Visa Find resource vi does not find GPIB0 board 
Author Message
 Visa Find resource vi does not find GPIB0 board

The GPIB0 board is appering in MAX device and interface. I can
communicate properly with my GPIB0::3::INSTR. While I run Visa Find
resource vi it finds all resources like serial and parallel ports,
GPIB0::3::INSTR instrument but it does not find GPIB0 board.
I running my application under WIN-98, labview 6.0 and NI-VISA 2.6 and
NI-VISA 2.6 Run Time are installed.


Sat, 09 Jul 2005 19:45:36 GMT  
 Visa Find resource vi does not find GPIB0 board
What expression are you using? Use ?* to return all resources and not
just instruments (serial and parallel ports are instrument resources).


Sat, 09 Jul 2005 23:11:04 GMT  
 Visa Find resource vi does not find GPIB0 board
Thank you Dennis,

I used ?*INSTR expression and it is a reason that I get the serial and
parallel ports only. While I am using ?* expression it return
GPIB0::INTFC with the ports.
Please advice how can I set the VISA resource name from element of
string array accepted by VISA Find resource?



Sun, 10 Jul 2005 00:30:21 GMT  
 Visa Find resource vi does not find GPIB0 board
You just have to index the element you want and wire it to the VISA
Resource Name of the VISA function you want to use. Strings are valid
inputs.


Sun, 10 Jul 2005 00:48:30 GMT  
 Visa Find resource vi does not find GPIB0 board
If you want to specifically look for GPIB board resources, remember
that the expression is a regular expression, so "?*INTFC" may be what
you want.

Also realize that when you want to connect to the GPIB board level
functions, you need to set the class of that refnum to "GPIB Board
Interface".

Dan Mondrik
Senior Software Engineer, NI-VISA
National Instruments



Sun, 10 Jul 2005 03:56:29 GMT  
 Visa Find resource vi does not find GPIB0 board
Thank yiu again for your help,

Now my application working properly. Please advice how I can set the
interface "GPIB0::INTFC" VISA alias to "GPIB0".
I can set instrument VISA alias by MAX but interface VISA alias can
not be changed by MAX.



Sun, 10 Jul 2005 21:58:33 GMT  
 Visa Find resource vi does not find GPIB0 board
Yes, you can do this too, although it is slightly less obvious.  In
MAX, choose Tools>>NI-VISA>>Alias Editor.  Click the "Add Alias"
button and enter both your alias ("GPIB0") and the full resource name
("GPIB0::INTFC").

Dan Mondrik



Sun, 10 Jul 2005 23:44:41 GMT  
 Visa Find resource vi does not find GPIB0 board
I set the interface alias "GPIB0" and it work properly.


Mon, 11 Jul 2005 14:16:01 GMT  
 
 [ 8 post ] 

 Relevant Pages 

1. VISA Find Resources and Open incorrect Error if VISA not installed

2. VISA Find function to VISA Resource Name

3. VISA Find Resource - illegal operation

4. Set Control Value returns error 15 ( Resource not found) after Application Building

5. Retrieving a vi diagram (.llb not found)

6. $canvas find enclosed does not find text with trailing newline

7. Find resources and resource name

8. Cannot open a VI: it keeps prompting me to find the VI

9. hen I launch my LabVIEW VI, I get following messages: Please find the VI

10. unable to find visa refnum

11. ITS NOT A VIRUS, ITS A 404 ERROR, FILE NOT FOUND

12. ITS NOT A VIRUS, ITS A 404 ERROR, FILE NOT FOUND

 

 
Powered by phpBB® Forum Software