Can't compile gforth-0.3.0 on Sparc Solaris 2.4 
Author Message
 Can't compile gforth-0.3.0 on Sparc Solaris 2.4

Quote:


> : I've tried to install gforth-0.3.0 on a SparcStation5 running under
> : SunOS Release 5.4 and got the following error messages after call of

> This is Gforth's "Solaris-User-Poll-Bug", as Bernd calls it.
> Include sys/filio.h in io.c, and everything works fine.
Yes. Bernd writes:

"In Solaris, FIONREAD is defined in <sys/filio.h>. This isn't very Posix,
but including this file after <sys/file.h> helps (in io.c)."

Nice to see Gforth's users answering before I see the original message
(in the News).

- anton
--
M. Anton Ertl                    Some things have to be seen to be believed

http://www.*-*-*.com/



Tue, 25 Jan 2000 03:00:00 GMT  
 
 [ 1 post ] 

 Relevant Pages 

1. Solaris 2.4, SPARC 1+, 8 bit color board, Sun's cc, Tk 4.0, test failure

2. Tcl 8.0b2 test fail - Solaris 2.4/SPARC/Sun compiler

3. Tk 8.0b2 test results for Solaris 2.4/SPARC/Sun compiler

4. gcc 2.7.2, sparc-solaris 2.4, and tcl 7.5

5. make test dumps core - Solaris/Sparc 2.4

6. Problems compiling on Sun 2.4 on Sparc 5

7. Compiling Fortran on Solaris 2.5 for 2.4

8. Help sought for compiling Python 1.4 on Solaris 2.4 with gcc 2.7.2

9. Compiling Python for Solaris 2.4

10. Compiling cprolog on Solaris 2.4 ?

11. compiling tcl/tk on Solaris 2.4 x86

12. Compiling Tcl/Tk 8.0 on Sun Solaris 2.4

 

 
Powered by phpBB® Forum Software