Grid problem....PLEASE HELP!!! 
Author Message
 Grid problem....PLEASE HELP!!!

In VFP3.0, I have a multipage form where the user clicks new to add
a new contract. Before the user clicks new, the textboxes background is grey
and readonly and the grid is the same.  The new button buffers the table for
the parent and appends a line; then buffers child table and appends a line.
It also changes the background of the textboxes and grids to white and they
are no longer readonly.  

Everything works fine.  The first field that the user enters is a combobox -
that is they select from the list.  If this is the first entry on this
particular screen, when they click on the combobox, the record in the grid
goes away and the grid cannot be edited.  If the user selects cancel and then
tries to enter the record for the second time, everything works fine.

My question, what makes me lose my grid?  I have tried several things in the
code to move the pointer and it doesn't correct this.

Thanks for any suggestions.

Susan Childress
My correct address:



Sun, 27 Aug 2000 03:00:00 GMT  
 Grid problem....PLEASE HELP!!!

Quote:

>In VFP3.0, I have a multipage form where the user clicks new to add
>a new contract. Before the user clicks new, the textboxes background is
grey
>and readonly and the grid is the same.  The new button buffers the table
for
>the parent and appends a line; then buffers child table and appends a line.
>It also changes the background of the textboxes and grids to white and they
>are no longer readonly.

>Everything works fine.  The first field that the user enters is a
combobox -
>that is they select from the list.  If this is the first entry on this
>particular screen, when they click on the combobox, the record in the grid
>goes away and the grid cannot be edited.  If the user selects cancel and
then
>tries to enter the record for the second time, everything works fine.

Make sure that  the data in the combo box  was not using the data in the
grid
or maybe it has a parent and child relataion in data environment and check
the
grid data property if it has a linkchild  or recordsource property.. This
cases
happen when you are using a child table in a grid....

Anyway in combobox interactive change property try to issue
select (record in the Grid)
Thisform.refresh()

I hope that this suggestion may help you.....

- Show quoted text -

Quote:

>My question, what makes me lose my grid?  I have tried several things in
the
>code to move the pointer and it doesn't correct this.

>Thanks for any suggestions.

>Susan Childress
>My correct address:




Sun, 03 Sep 2000 03:00:00 GMT  
 
 [ 2 post ] 

 Relevant Pages 

1. Grid problem, please help!

2. Little grid problem...please help!

3. COMBO BOX, PLEASE HELP, PLEASE HELP, PLEASE HELP!

4. Please HELP... Grid Problem

5. Please Help With Grid Problem

6. Please HELP!: Grid, ComboBox problem

7. PLEASE HELP: problem sorting child grid in VFP3

8. Please Help -- Grid Problem 5.0

9. problems with grid and addobject() - please help

10. Please, Please help me with this ODBC FoxPro INSERT Problem

11. help blank grid please

12. Please Help Me ! Grid and SQL - Update

 

 
Powered by phpBB® Forum Software