VFP 5.0 and NT 4.0 and running out of Virtual memory 
Author Message
 VFP 5.0 and NT 4.0 and running out of Virtual memory

Foxpro returned wrong answers with no error when VM ran out on me.  The
server was fine otherwise and no other casualties were noted.  I am
wondering though, if just high VM utilization will produce these wrong
answers.  This would explain a problem that I have been having with
random missing information.

Has anyone else run into this problem?

I have increased the amount of VM in the meantime. I am now at 40% over
real memory.  For those that have followed MS recommendation of 20% over
real, it might be prudent to allocate more.

Mike



Tue, 29 Feb 2000 03:00:00 GMT  
 VFP 5.0 and NT 4.0 and running out of Virtual memory

Mike,
Here's an extract from the online documentation - performance tuning.  It
may be relevant:
Windows NT
For the most part, the Windows NT? operating system and Visual FoxPro work
extremely well together. The only exception is when you run Visual FoxPro
on a Windows NT Server. The Windows NT Server uses far more memory than
Visual FoxPro expects, and therefore Visual FoxPro can tend to
over-allocate memory for its own uses.
To remedy this, you should use the SYS (3050) system function to adjust
Visual FoxPros memory buffer pool to approximately one third of its
default (see the Memory Management section below). For example, you could
add the following code to your startup code or your CONFIG.FPW file:

=SYS (3050, VAL (SYS (3050, 1, 0)) / 3)
HTH
Stuart Lewis



Quote:
> Foxpro returned wrong answers with no error when VM ran out on me.  The
> server was fine otherwise and no other casualties were noted.  I am
> wondering though, if just high VM utilization will produce these wrong
> answers.  This would explain a problem that I have been having with
> random missing information.



Wed, 01 Mar 2000 03:00:00 GMT  
 VFP 5.0 and NT 4.0 and running out of Virtual memory

Stuart,

Thanks, I am using this function to limit the amount of RAM used by
Foxpro, but what concerns me is that Foxpro seems to return random
results (all wrong of course) with no error message of any kind.  

Mike

Quote:

> Mike,
> Here's an extract from the online documentation - performance tuning.  It
> may be relevant:
> Windows NT
> For the most part, the Windows NT? operating system and Visual FoxPro work
> extremely well together. The only exception is when you run Visual FoxPro
> on a Windows NT Server. The Windows NT Server uses far more memory than
> Visual FoxPro expects, and therefore Visual FoxPro can tend to
> over-allocate memory for its own uses.
> To remedy this, you should use the SYS (3050) system function to adjust
> Visual FoxPros memory buffer pool to approximately one third of its
> default (see the Memory Management section below). For example, you could
> add the following code to your startup code or your CONFIG.FPW file:

> =SYS (3050, VAL (SYS (3050, 1, 0)) / 3)
> HTH
> Stuart Lewis



> > Foxpro returned wrong answers with no error when VM ran out on me.  The
> > server was fine otherwise and no other casualties were noted.  I am
> > wondering though, if just high VM utilization will produce these wrong
> > answers.  This would explain a problem that I have been having with
> > random missing information.



Fri, 03 Mar 2000 03:00:00 GMT  
 
 [ 3 post ] 

 Relevant Pages 

1. VFP 5.0 app in Windows NT 4.0 does not run

2. VFP 5.0 app running on NT 4.0

3. Fox 2.6 Windows runs out of memory under NT 4.0

4. Problema con los formularios para Exchange 4.0 y Exchange 5.0 para Windows NT 4.0

5. Of Dr. Watson, VFP 5.0 and NT 4.0

6. VFP 5.0 & NT 4.0

7. VFP 5.0 atrocious performance in NT 4.0

8. VFP 5.0 Professional & NT 4.0 Server Install

9. Help! VFP 5.0 wizard problem under NT 4.0

10. Serious bug in VFP 5.0 under NT 4.0??

11. VFP 5.0 Memory Allocation under NT

12. Foxpro for DOS 2.6 / Memory problems on NT 4.0

 

 
Powered by phpBB® Forum Software