Having a real problem with Print Preview. 
Author Message
 Having a real problem with Print Preview.

A user brings up a report in print pre-view.

If the report is less than one page and a user clicks on
the report, the cursor is a magnifying glass, about 1/2
the time the user gets a varaible not found. If I delete
this variable from the report the error goes to another
variable. What is happening is that the report pre-view
is loosing touch with the cursor.

Other prople have said this happens with grids on forms
at times.

One user told me to hide the report screen and that
seemed to help some. I also hide, make invisable, all
open screens to no avial. I also try defining my own
screen to open the print pre-view in but to no avail.

It is intermittent. Most times if you get the error and
then run the pre-view again it works over and over.

Seems to be a bug in Foxpro's print pre-view. If I choose
the percentage zoom settings it always works. If I just
click on the pre-view to do the same thing it fails
intermittnetly.

I downloaded VFP 8 beta and tried it but it fails there
also.

Instead of assinging a specific table to the report I
create a cursor with SQL.

Any help would be greatly appreciated.

We just finished this program and am sending it out to
users around the country.

Thanks in Advance

Frank



Sat, 30 Jul 2005 10:41:43 GMT  
 Having a real problem with Print Preview.

use private datasession on that report :)

Sen
you haven't try to use private datasession, aren't you ?

Quote:
>-----Original Message-----
>A user brings up a report in print pre-view.

>If the report is less than one page and a user clicks on
>the report, the cursor is a magnifying glass, about 1/2
>the time the user gets a varaible not found. If I delete
>this variable from the report the error goes to another
>variable. What is happening is that the report pre-view
>is loosing touch with the cursor.

>Other prople have said this happens with grids on forms
>at times.

>One user told me to hide the report screen and that
>seemed to help some. I also hide, make invisable, all
>open screens to no avial. I also try defining my own
>screen to open the print pre-view in but to no avail.

>It is intermittent. Most times if you get the error and
>then run the pre-view again it works over and over.

>Seems to be a bug in Foxpro's print pre-view. If I choose
>the percentage zoom settings it always works. If I just
>click on the pre-view to do the same thing it fails
>intermittnetly.

>I downloaded VFP 8 beta and tried it but it fails there
>also.

>Instead of assinging a specific table to the report I
>create a cursor with SQL.

>Any help would be greatly appreciated.

>We just finished this program and am sending it out to
>users around the country.

>Thanks in Advance

>Frank
>.



Sat, 30 Jul 2005 13:56:42 GMT  
 Having a real problem with Print Preview.
Frank,

If you still are having problems with "Variable not found" message, maybe
you can try to declare these variables as public before running report. I
know, it is breaking OOP rules, but could be first aid if you have
deadline...

HTH
Slobodan


Quote:
> A user brings up a report in print pre-view.

> If the report is less than one page and a user clicks on
> the report, the cursor is a magnifying glass, about 1/2
> the time the user gets a varaible not found. If I delete
> this variable from the report the error goes to another
> variable. What is happening is that the report pre-view
> is loosing touch with the cursor.

> Other prople have said this happens with grids on forms
> at times.

> One user told me to hide the report screen and that
> seemed to help some. I also hide, make invisable, all
> open screens to no avial. I also try defining my own
> screen to open the print pre-view in but to no avail.

> It is intermittent. Most times if you get the error and
> then run the pre-view again it works over and over.

> Seems to be a bug in Foxpro's print pre-view. If I choose
> the percentage zoom settings it always works. If I just
> click on the pre-view to do the same thing it fails
> intermittnetly.

> I downloaded VFP 8 beta and tried it but it fails there
> also.

> Instead of assinging a specific table to the report I
> create a cursor with SQL.

> Any help would be greatly appreciated.

> We just finished this program and am sending it out to
> users around the country.

> Thanks in Advance

> Frank



Sat, 30 Jul 2005 14:03:58 GMT  
 Having a real problem with Print Preview.
Frank,


Quote:
> A user brings up a report in print pre-view.

> If the report is less than one page and a user clicks on
> the report, the cursor is a magnifying glass, about 1/2
> the time the user gets a varaible not found. If I delete
> this variable from the report the error goes to another
> variable. What is happening is that the report pre-view
> is loosing touch with the cursor.

> Other prople have said this happens with grids on forms
> at times.

If you have a grid on your form, get the focus off the grid (set the focus
to a textbox or so), select the report's table/cursor, then preview the
report
Quote:
> One user told me to hide the report screen and that
> seemed to help some. I also hide, make invisable, all
> open screens to no avial. I also try defining my own
> screen to open the print pre-view in but to no avail.

> It is intermittent. Most times if you get the error and
> then run the pre-view again it works over and over.

> Seems to be a bug in Foxpro's print pre-view. If I choose
> the percentage zoom settings it always works. If I just
> click on the pre-view to do the same thing it fails
> intermittnetly.

> I downloaded VFP 8 beta and tried it but it fails there
> also.

> Instead of assinging a specific table to the report I
> create a cursor with SQL.

> Any help would be greatly appreciated.

> We just finished this program and am sending it out to
> users around the country.

> Thanks in Advance

> Frank



Sat, 30 Jul 2005 16:03:43 GMT  
 Having a real problem with Print Preview.
Thanks Slobodan.

I will try that.

The only problem I see is that the report will run 3
times and fail on the 4th and then run 50 more times.
Kinda intermittent.

If you want you can go to our web site at
www.sareansoft.com and download our demo, on the products
page, and try it. At least you can see what another
programmer is programming. It should fail if you select
some criteria from the reports page and run the by
customer report, etc.

I have had a problem running the demo on a machine I have
VFP7 on. On a machine without VFP installed it works
great. When I run the program using the Icon it creates
on the workspace it bombs. Maybe you can shed some light
on that.

On a system with VFP install I have to create a new Icon
and run the sra.exe pgm but have to put the "Start In"
as "C:\Program Files\Microsoft Visual FoxPro 7"

Have a great one!

:)

Frank

Quote:
>-----Original Message-----
>Frank,

>If you still are having problems with "Variable not

found" message, maybe
Quote:
>you can try to declare these variables as public before
running report. I
>know, it is breaking OOP rules, but could be first aid
if you have
>deadline...

>HTH
>Slobodan



>> A user brings up a report in print pre-view.

>> If the report is less than one page and a user clicks
on
>> the report, the cursor is a magnifying glass, about 1/2
>> the time the user gets a varaible not found. If I
delete
>> this variable from the report the error goes to another
>> variable. What is happening is that the report pre-view
>> is loosing touch with the cursor.

>> Other prople have said this happens with grids on forms
>> at times.

>> One user told me to hide the report screen and that
>> seemed to help some. I also hide, make invisable, all
>> open screens to no avial. I also try defining my own
>> screen to open the print pre-view in but to no avail.

>> It is intermittent. Most times if you get the error and
>> then run the pre-view again it works over and over.

>> Seems to be a bug in Foxpro's print pre-view. If I
choose
>> the percentage zoom settings it always works. If I just
>> click on the pre-view to do the same thing it fails
>> intermittnetly.

>> I downloaded VFP 8 beta and tried it but it fails there
>> also.

>> Instead of assinging a specific table to the report I
>> create a cursor with SQL.

>> Any help would be greatly appreciated.

>> We just finished this program and am sending it out to
>> users around the country.

>> Thanks in Advance

>> Frank

>.



Sat, 30 Jul 2005 16:55:56 GMT  
 
 [ 5 post ] 

 Relevant Pages 

1. - How to display Print Preview bar when previewing IN DESKTOP

2. Print Preview problem

3. Report Print Preview Problem

4. Print preview display problem

5. Print preview problems running XP

6. Print preview problem in Windows Foxpro2.5

7. Print Preview Problem

8. Print Preview Problem

9. i have problems with the print preview

10. Print Preview problem

11. Print Preview Problem

12. Print Preview problem

 

 
Powered by phpBB® Forum Software