License not found. URGENT!!! 
Author Message
 License not found. URGENT!!!

Many of the active-x controls will not let you add them to a container at
runtime.  When that is being done they think that your in development mode,
and this requires a different license then just to use them.  The only way I
know to handle this is either to put them on the form in design mode, or to
put them into a container that you can then add at runtime.  This is the
only way *I* know of to do this (and yes, I have run into this problem with
some controls)

--
Cy Welch
Senior Programmer/Analyst
MetSYS Inc

Quote:
> Using VFP6, I tried to distribute my app, which uses the mswinsock.ocx.
> I've tried using Wise and I've tried using the Setup Wizard.

> Both of them install the file and then, when I do a createobject, tell me
> that the required license is not found.

> How the hell do I get around this?  I assume I'm supposed to be able to
> distribute the OCX's that come with VFP6, or they wouldn't be there in the
> first place.

> Andy D



Sun, 23 Feb 2003 09:56:15 GMT  
 License not found. URGENT!!!
You have _no_ idea how grateful I'm feeling right now.

I added the object to a form by drag and drop and 'bingo' it worked.

Of course, this isn't documented _anywhere_.

I now need to update all of my network code to work with this.

Aaagghhh!!!

Andy D

(off to MS with an axe)


Quote:
>Many of the active-x controls will not let you add them to a container
>at runtime.  When that is being done they think that your in development
>mode, and this requires a different license then just to use them.  The
>only way I know to handle this is either to put them on the form in
>design mode, or to put them into a container that you can then add at
>runtime.  This is the only way *I* know of to do this (and yes, I have
>run into this problem with some controls)

>--
>Cy Welch
>Senior Programmer/Analyst
>MetSYS Inc


>> Using VFP6, I tried to distribute my app, which uses the
>> mswinsock.ocx. I've tried using Wise and I've tried using the Setup
>> Wizard.

>> Both of them install the file and then, when I do a createobject, tell
>> me that the required license is not found.

>> How the hell do I get around this?  I assume I'm supposed to be able
>> to distribute the OCX's that come with VFP6, or they wouldn't be there
>> in the first place.

>> Andy D



Sun, 23 Feb 2003 17:41:31 GMT  
 License not found. URGENT!!!
Also look at KB article
http://support.microsoft.com/support/kb/articles/Q146/2/19.ASP
for info at registering ocx'es

Greetings,

Ko Wisse
VFP'er
FlexiSoft
the Netherlands



Mon, 24 Feb 2003 02:22:22 GMT  
 
 [ 3 post ] 

 Relevant Pages 

1. OLE error code 0x80040112: Appropriate license for this class not found

2. Appropriate license not found

3. OLE error code 0x80040112:Appropriate license not found

4. "OLE error code 0x80040112:Appropriate license for this class not found

5. ActiveX Problem - Appropriate License for this Class Not Found

6. Appropriate license not found, using MSCOMM32.OCX

7. HELP : OLE error code 0x90040112: Appropiate license for this class not found

8. Error 1426 - OLE error: Appropriate license for this class not found

9. Do while found--- what if not found?

10. FOUND VFP5.0 GRID BUG - Column not found error

11. MSMAPI Error, Class is not licensed for use in windows XP

12. "Class is not licensed for use."

 

 
Powered by phpBB® Forum Software