No table is open in the current work area when setfocus 
Author Message
 No table is open in the current work area when setfocus

When I do fullobjectname.setfocus, the error message 'No
table is open in the current work area' is coming. The
object is a grid and data is there. I feel it happens more
often when there are more records in the grid.

Any ideas? TIA.



Mon, 25 Jul 2005 18:09:42 GMT  
 No table is open in the current work area when setfocus
When you say fullobjectname, do you mean
oFormName.grdGridName.setfocus, or
thisform.grdGridName.setfocus?  Where is the code running?

I've seen where using oFormname.... before the init of the
form finsihed will cause problems.  Something about the
varible oFormName not getting created or "linked" to the
form object until after the form's init runs.

John B.

Quote:
>-----Original Message-----
>When I do fullobjectname.setfocus, the error message 'No
>table is open in the current work area' is coming. The
>object is a grid and data is there. I feel it happens
more
>often when there are more records in the grid.

>Any ideas? TIA.

>.



Mon, 25 Jul 2005 21:54:22 GMT  
 
 [ 2 post ] 

 Relevant Pages 

1. No table is open in the current work area

2. Help: No table is open in the current work area

3. Help needed: No tables open in current work area

4. when are Open work areas not open!!

5. Current work area being reset by form somehow

6. TableUpdate() switches the current work area

7. API - set current work area?

8. VFP Debug - Tracking open work areas

9. Error: No table is open in the current work area.

10. Indexes that reffers to tables in another work area

11. Indexes that refer to tables in another work area

12. open table dialog even though table is open?

 

 
Powered by phpBB® Forum Software