Word Automation and Norton's Antivirus 2002 
Author Message
 Word Automation and Norton's Antivirus 2002

Hi all,

Here is my new problem...
I can open a blank word document with the code written down below only when
I disable Norton's Antivirus 2002.

I have tracked it down to an option (NAV) in the Miscellaneous tab that
enables Office Plug-in is ticked. When it is disabled, it works fine
otherwise it doesn't.

Do I need to send an email to Symantec for this, or is there some way of
by-passing this through code or does anyone else have the same problem with
NAV.

The code I have as follows
set oleobject on
public oword

oword=createobject("word.application")
oword.visible=.t.

odocument=oword.documents.add()



Sat, 29 Jan 2005 07:39:47 GMT  
 Word Automation and Norton's Antivirus 2002
We ran across the same problem and found that in order to stop this we had
to disable that function in Norton.
The easiest way we found to do this was to use a batch file to unregister
the .dll that does the scanning.  The contents of the batch file are as
follows.

regsvr32 /u "c:\program files\norton antivirus\officeav.dll"

Bradley Buchanan
Systems Programmer
(423)636-7300 ext 7655


Quote:
> Hi all,

> Here is my new problem...
> I can open a blank word document with the code written down below only
when
> I disable Norton's Antivirus 2002.

> I have tracked it down to an option (NAV) in the Miscellaneous tab that
> enables Office Plug-in is ticked. When it is disabled, it works fine
> otherwise it doesn't.

> Do I need to send an email to Symantec for this, or is there some way of
> by-passing this through code or does anyone else have the same problem
with
> NAV.

> The code I have as follows
> set oleobject on
> public oword

> oword=createobject("word.application")
> oword.visible=.t.

> odocument=oword.documents.add()



Sat, 29 Jan 2005 22:21:26 GMT  
 Word Automation and Norton's Antivirus 2002
Had the same problem when I tried to use a general field into a
report. The automation worked fine on 6 machines but did not work on
the one machine that had Norton on it. We called Symantec and worked
with the tech man for two days. He could not fix it. He even had
control of the machine via the internet. I finally removed Norton,
(That was a {*filter*} of a job, has its web all over the machine) I
installed PC Chilling Anti Virus. Have not had a problem since. I
think Norton goes to far with its checking. It slows the machine down
and wants to check each and every DOC file you open. It also plays
havoc with PC AnyWhere. It protects your machine but the overhead is
to much for me.
TonySper


Hi all,

Here is my new problem...
I can open a blank word document with the code written down below only
when
I disable Norton's Antivirus 2002.

I have tracked it down to an option (NAV) in the Miscellaneous tab
that
enables Office Plug-in is ticked. When it is disabled, it works fine
otherwise it doesn't.

Do I need to send an email to Symantec for this, or is there some way
of
by-passing this through code or does anyone else have the same problem
with
NAV.

The code I have as follows
set oleobject on
public oword

oword=createobject("word.application")
oword.visible=.t.

odocument=oword.documents.add()



Sun, 30 Jan 2005 05:11:23 GMT  
 Word Automation and Norton's Antivirus 2002
Yep, had the same problem myself with the configuration of:
FPW 2.6
Windows XP (Pro)
Word 2000 (from office)
Norton AV 2002

However, the move to VFP5 cured it on its own as did the
move to VFP7.

Anyone else get the same results just by changing to VFP?

Ian

Quote:
>-----Original Message-----
>We ran across the same problem and found that in order to
stop this we had
>to disable that function in Norton.
>The easiest way we found to do this was to use a batch
file to unregister
>the .dll that does the scanning.  The contents of the
batch file are as
>follows.

>regsvr32 /u "c:\program files\norton

antivirus\officeav.dll"
Quote:

>Bradley Buchanan
>Systems Programmer
>(423)636-7300 ext 7655



>> Hi all,

>> Here is my new problem...
>> I can open a blank word document with the code written
down below only
>when
>> I disable Norton's Antivirus 2002.

>> I have tracked it down to an option (NAV) in the

Miscellaneous tab that

- Show quoted text -

Quote:
>> enables Office Plug-in is ticked. When it is disabled,
it works fine
>> otherwise it doesn't.

>> Do I need to send an email to Symantec for this, or is
there some way of
>> by-passing this through code or does anyone else have
the same problem
>with
>> NAV.

>> The code I have as follows
>> set oleobject on
>> public oword

>> oword=createobject("word.application")
>> oword.visible=.t.

>> odocument=oword.documents.add()

>.



Wed, 02 Feb 2005 08:16:02 GMT  
 
 [ 4 post ] 

 Relevant Pages 

1. Word automation in Windows XP/Word 2002

2. VFP and Norton AntiVirus

3. FoxPro Database on LAN slowed by Norton AntiVirus AutoProtect

4. Norton AntiVirus Slows VFP / Why?

5. How To Connect Visual FoxPro 7 Data Source to Word 2002 (or Office XP Applications)

6. Word 2002 Error Message: Unable to Open Data Source using Visual FoxPro Data Base File

7. VFP5 OLE Automation Error (Word '97)

8. Word automation - closing Word..

9. Attach File on OUTLOOK 2002

10. Accessing FoxPro tables with Access 2002

11. VIM 2002.02.180 -- Asynchronous (Event) Network processing added

12. Jan 2002 MSDN - where is the VFP help?

 

 
Powered by phpBB® Forum Software