Deleting records from table 
Author Message
 Deleting records from table

I'm having a problem with deleting records from a certain table. I'm trying
to delete detail records from a file through a form. I have a grid on the
form with a "Remove Record" button. When I click the button it does mark it
for deletion in the file and so removes it from the grid. But when I close
the form and then re-open it and go to the same record, the details that I
deleted from the grid are back. I've set up some code at various places in
the program that will browse the table to see if the records are actually
marked for deletion and they are. I followed this through right to the
"Close" button on the form and the records are still marked for deletion,
but at some place they are being recalled. When I close the form and close
the program and look at the file, the records are no longer marked for
deletion. Is there something I'm doing wrong with the way I'm handling the
table? I have the table's buffermodeoverride property set to 1-Use Form
Setting and I have the form buffermode property set to 1-Pessimistic. Is
there some other setting I need to set. Any help will be greatly
appreciated.

Thanks.

Doug



Thu, 05 Jan 2006 09:33:06 GMT  
 Deleting records from table
Did you do a TABLEUPDATE() after you deleted the records?

--

Fred
Microsoft Visual FoxPro MVP
Please respond only to the newsgroups so that all may benefit.

Quote:

> I'm having a problem with deleting records from a certain table. I'm
> trying to delete detail records from a file through a form. I have a
> grid on the form with a "Remove Record" button. When I click the
> button it does mark it for deletion in the file and so removes it
> from the grid. But when I close the form and then re-open it and go
> to the same record, the details that I deleted from the grid are
> back. I've set up some code at various places in the program that
> will browse the table to see if the records are actually marked for
> deletion and they are. I followed this through right to the "Close"
> button on the form and the records are still marked for deletion, but
> at some place they are being recalled. When I close the form and
> close the program and look at the file, the records are no longer
> marked for deletion. Is there something I'm doing wrong with the way
> I'm handling the table? I have the table's buffermodeoverride
> property set to 1-Use Form Setting and I have the form buffermode
> property set to 1-Pessimistic. Is there some other setting I need to
> set. Any help will be greatly appreciated.

> Thanks.

> Doug

---
Outgoing mail is certified Virus Free.
Checked by AVG anti-virus system (http://www.grisoft.com).
Version: 6.0.501 / Virus Database: 299 - Release Date: 7/14/2003


Thu, 05 Jan 2006 11:11:05 GMT  
 Deleting records from table
I can't believe this but no I didn't.do a TABLEUPDATE(). I thought I had.
Thanks for the help.

Doug


Quote:
> Did you do a TABLEUPDATE() after you deleted the records?

> --

> Fred
> Microsoft Visual FoxPro MVP
> Please respond only to the newsgroups so that all may benefit.


> > I'm having a problem with deleting records from a certain table. I'm
> > trying to delete detail records from a file through a form. I have a
> > grid on the form with a "Remove Record" button. When I click the
> > button it does mark it for deletion in the file and so removes it
> > from the grid. But when I close the form and then re-open it and go
> > to the same record, the details that I deleted from the grid are
> > back. I've set up some code at various places in the program that
> > will browse the table to see if the records are actually marked for
> > deletion and they are. I followed this through right to the "Close"
> > button on the form and the records are still marked for deletion, but
> > at some place they are being recalled. When I close the form and
> > close the program and look at the file, the records are no longer
> > marked for deletion. Is there something I'm doing wrong with the way
> > I'm handling the table? I have the table's buffermodeoverride
> > property set to 1-Use Form Setting and I have the form buffermode
> > property set to 1-Pessimistic. Is there some other setting I need to
> > set. Any help will be greatly appreciated.

> > Thanks.

> > Doug

> ---
> Outgoing mail is certified Virus Free.
> Checked by AVG anti-virus system (http://www.grisoft.com).
> Version: 6.0.501 / Virus Database: 299 - Release Date: 7/14/2003



Thu, 05 Jan 2006 11:35:58 GMT  
 
 [ 3 post ] 

 Relevant Pages 

1. Deleted records in table with candidate key

2. Deleted records in table with candidate key

3. Problem with deleting records and table buffering

4. Deleted records in table with candidate key

5. Deleted records in base table appearing in view

6. Adding a new record to a table after a delete

7. Ineed to delete records from multiple tables

8. I need to delete records from multiple tables

9. How to prevent records in a table from being deleted

10. Deleted Records in 2.6 Tables

11. How to delete particular record in child table

12. deleted records still show in table

 

 
Powered by phpBB® Forum Software