VFP 8.0 - Adapter Class 
Author Message
 VFP 8.0 - Adapter Class

I asked this earlier and made all the suggestions and still doesn't work.
Please look below and see if I am doing anything wrong:

PUBLIC oAdapter
lcSql = "SELECT nlocation, cDesc FROM tblLocation"
? SQLEXEC( gnCH, lcSql, "location" ) && RETURNS 1

oAdapter = CREATEOBJECT( "CursorAdapter" )
oAdapter.Alias = "Location"
oAdapter.Tables = "tblLocation"
oAdapter.CursorSchema = "nLocation I, cDesc C(20)"
oAdapter.KeyFieldList = "nlocation"
oAdapter.UpdateNameList = "nlocation,cdesc"
oAdapter.UpdatableFieldList = "nlocation,cdesc"
oAdapter.DataSourceType = "ODBC"
oAdapter.DataSource = gnCH
oAdapter.WhereType = 1
oAdapter.SendUpdates = .T.
oAdapter.AllowInsert = .T.
oAdapter.AllowDelete = .T.
oAdapter.AllowUpdate = .T.

? oAdapter.CursorAttach( "location" )  && RETURNS .T.
? oAdapter.CursorStatus  && RETURNS 2
INSERT INTO Location ( nlocation, cdesc ) VALUES ( 200, "SPRINGFIELD" )
? TABLEUPDATE( .T. ) && RETURNS .T.

I close the cursor.
Check SQL Server.
Updates are not there.

HELP!!!!!



Thu, 19 May 2005 06:56:16 GMT  
 
 [ 1 post ] 

 Relevant Pages 

1. Adapter Class Not Updating Data On Server Side

2. LAN Adapter Number in VFP 6.0

3. Dialup-Adapter in VFP

4. VFP 8 Cursor Adapters

5. VFP 8 Cursor Adapter

6. VFP 6 Class browser bombs when opening a VFP 5 class library

7. VFP 8.0 and VFP 6.0

8. Managing Classes with Class Browser - I cannot copy a class from one class library to another

9. VFP - Adding Classes to Class Libraries from .prg files

10. VFP 8.0 & Win ME

11. VFP 8.0 Help

12. NULL When Returning Arrays From VFP 8.0 Com Servers

 

 
Powered by phpBB® Forum Software