VFP 8 Install and ActiveX 
Author Message
 VFP 8 Install and ActiveX

Ever since I installed VFP 8 when running a VFP 6 application that creates
ActiveX controls like the progressbar and tree controls provided by
Microsoft, I get a Windows Installer message that reads preparing to
install. It's there for about 15 secs and then disappears. This happens on
forms where I load the activex control programmatoically (so OLE info is not
stored inthe form).

Once the form comes up I can close and re-run and the WIndows Installer
message doesn't come up again. However, if I wait long evnough, 5-10 minutes
it will appear again when I load the form. THis is not only highly annoying
but very ineeficient when developing to keepo having to wait for this dialog
to go away.

Anyway else see this problem and have a solution??

Thanks

Mike



Tue, 06 Sep 2005 00:39:54 GMT  
 VFP 8 Install and ActiveX
Hello, Mike!
You wrote  on Thu, 20 Mar 2003 10:39:54 -0600:

 M> Once the form comes up I can close and re-run and the WIndows Installer
 M> message doesn't come up again. However, if I wait long evnough, 5-10
 M> minutes it will appear again when I load the form. THis is not only
 M> highly annoying but very ineeficient when developing to keepo having to
 M> wait for this dialog to go away.

 M> Anyway else see this problem and have a solution??

 M> Thanks

 M> Mike

I had the same problem. If you're running Win2k or WinXP, check the
Application or System errorlog. I dont remember the exact error code / event
number, but if you browse through the messages, you'll find a GUID or CLSID
of the component (file)that is missing, invalid, or not correctly
registered. Locate the GUID in your registry to learn more about the
specific file. In my case, the VC 7 runtime library dll was registered to be
in the root of drive D:. Once I put the correct location of the VC runtime
dll in the registry, the problem was gone.

Before doing this, try to run the repair function of the VFP8 installer.
---
Eric den Doop
www.foxite.com - The Home Of The Visual FoxPro Experts - Powered By VFP8



Tue, 06 Sep 2005 01:43:33 GMT  
 VFP 8 Install and ActiveX
Eric,

Thanks! I see similar entries.

Mike



Quote:
> Hello, Mike!
> You wrote  on Thu, 20 Mar 2003 10:39:54 -0600:

>  M> Once the form comes up I can close and re-run and the WIndows
Installer
>  M> message doesn't come up again. However, if I wait long evnough, 5-10
>  M> minutes it will appear again when I load the form. THis is not only
>  M> highly annoying but very ineeficient when developing to keepo having
to
>  M> wait for this dialog to go away.

>  M> Anyway else see this problem and have a solution??

>  M> Thanks

>  M> Mike

> I had the same problem. If you're running Win2k or WinXP, check the
> Application or System errorlog. I dont remember the exact error code /
event
> number, but if you browse through the messages, you'll find a GUID or
CLSID
> of the component (file)that is missing, invalid, or not correctly
> registered. Locate the GUID in your registry to learn more about the
> specific file. In my case, the VC 7 runtime library dll was registered to
be
> in the root of drive D:. Once I put the correct location of the VC runtime
> dll in the registry, the problem was gone.

> Before doing this, try to run the repair function of the VFP8 installer.
> ---
> Eric den Doop
> www.foxite.com - The Home Of The Visual FoxPro Experts - Powered By VFP8



Tue, 06 Sep 2005 04:20:51 GMT  
 
 [ 3 post ] 

 Relevant Pages 

1. Installing MSHTML ActiveX controls from VFP

2. How to install DLL's when installing a VFP app

3. What ActiveX Controls are installed?

4. Installing IDSmail activex on users machine

5. installing activex control?

6. Installing ActiveX controls

7. Install of VFP7.0 After Install of .Net Beta 1

8. Firing events from one activex to another activex

9. Excel workbook activex and Word activeX

10. how can i install vfp sp1

11. 95/VFP: ODBC Not Installing

12. Installing VFP - GPF

 

 
Powered by phpBB® Forum Software