App Talking Back 
Author Message
 App Talking Back

I recently wrote a small application consisting of a group of modeless forms
launched from a form containing hyperlinks. On most workstations here, the
application works fine. Workstations are running Win98, NT Workstation and
W2K Workstation.

On one particular workstation, the application "talks" on the forms. As each
form is launched, the app "talks" on the window that just lost focus.

I've tried everything I can think of, setting Resource off (both in the app
and in a config.fpw), setting talk off, etc. Nothing seems to work.

Any ideas?

TIA

Jory Liebman
ASAP of Georgia, Inc.



Sun, 09 Mar 2003 03:00:00 GMT  
 App Talking Back
Have you tried 'set notify off' ???

Marie



Quote:

> I recently wrote a small application consisting of a group of modeless
forms
> launched from a form containing hyperlinks. On most workstations here, the
> application works fine. Workstations are running Win98, NT Workstation and
> W2K Workstation.

> On one particular workstation, the application "talks" on the forms. As
each
> form is launched, the app "talks" on the window that just lost focus.

> I've tried everything I can think of, setting Resource off (both in the
app
> and in a config.fpw), setting talk off, etc. Nothing seems to work.

> Any ideas?

> TIA

> Jory Liebman
> ASAP of Georgia, Inc.

-----= Posted via Newsfeeds.Com, Uncensored Usenet News =-----
http://www.newsfeeds.com - The #1 Newsgroup Service in the World!
-----==  Over 80,000 Newsgroups - 16 Different Servers! =-----


Sun, 09 Mar 2003 03:00:00 GMT  
 App Talking Back
set talk off
set talk window
set notify off
set status off

Regards,

Quote:
>Subject: App Talking Back

>Date: 9/20/2000 6:35 AM Pacific Daylight Time

>I recently wrote a small application consisting of a group of modeless forms
>launched from a form containing hyperlinks. On most workstations here, the
>application works fine. Workstations are running Win98, NT Workstation and
>W2K Workstation.

>On one particular workstation, the application "talks" on the forms. As each
>form is launched, the app "talks" on the window that just lost focus.

>I've tried everything I can think of, setting Resource off (both in the app
>and in a config.fpw), setting talk off, etc. Nothing seems to work.

>Any ideas?

>TIA

>Jory Liebman
>ASAP of Georgia, Inc.

Mike


Sun, 09 Mar 2003 03:00:00 GMT  
 App Talking Back
Jory,

SET TALK is scoped to the datasession. In your lowest level form class you
should SET TALK OFF in the Load() method. See the SET DATASESSION help topic
for more information.
--
df    - (Microsoft FoxPro MVP) http://www.geocities.com/df_FoxPro/

Quote:

> I recently wrote a small application consisting of a group of modeless
forms
> launched from a form containing hyperlinks. On most workstations here, the
> application works fine. Workstations are running Win98, NT Workstation and
> W2K Workstation.

> On one particular workstation, the application "talks" on the forms. As
each
> form is launched, the app "talks" on the window that just lost focus.

> I've tried everything I can think of, setting Resource off (both in the
app
> and in a config.fpw), setting talk off, etc. Nothing seems to work.



Mon, 10 Mar 2003 03:00:00 GMT  
 App Talking Back

Thanks to all respondees. David's solution is correct, but the root of the
problem was in the installation of VFP on the workstation. This user had
VFP5 and VFP6 installed concurrently at some time in the past.

When he deinstalled VS 6 and reinstalled it, the problem went away.

Thanks

Jory


Quote:
> Jory,

> SET TALK is scoped to the datasession. In your lowest level form class you
> should SET TALK OFF in the Load() method. See the SET DATASESSION help
topic
> for more information.
> --
> df    - (Microsoft FoxPro MVP) http://www.geocities.com/df_FoxPro/




Quote:

> > I recently wrote a small application consisting of a group of modeless
> forms
> > launched from a form containing hyperlinks. On most workstations here,
the
> > application works fine. Workstations are running Win98, NT Workstation
and
> > W2K Workstation.

> > On one particular workstation, the application "talks" on the forms. As
> each
> > form is launched, the app "talks" on the window that just lost focus.

> > I've tried everything I can think of, setting Resource off (both in the
> app
> > and in a config.fpw), setting talk off, etc. Nothing seems to work.



Mon, 10 Mar 2003 03:00:00 GMT  
 
 [ 5 post ] 

 Relevant Pages 

1. Backing Up File in a FozPro App

2. Talk me into using VFP. Talk me out of using VFP.

3. VFP7 set talk off

4. find GUO XIN(man who had a talk with me about VFP in MS-Netmeeting)

5. VFP7 SQL-Select and SET TALK

6. VFP7 SQL-Select and SET TALK

7. Talking to other Programs

8. talk in message line

9. SET TALK and SELECT SQL

10. Form does not talk to caller

11. FA: The Pros Talk Fox (Pinnacle Publishing)

12. Talking to the Editor

 

 
Powered by phpBB® Forum Software