VFP Rushmore optimization not kicking in 
Author Message
 VFP Rushmore optimization not kicking in

I'm new to VFP and I'm trying to do something very simple (!).  When I
do the following in the command window I get the message that the
Rushmore optimization level is none.

sys(3054,1)
select company,cust_id from customer where cust_id = "ANTON" into cursor
temp

This customer table is the one that ships with VFP and is in the
samples\data folder.  It has a tag on cust_id.  If I add a tag to the
file called Deleted with deleted() as the key and do the same thing I
get partial optimization.  This isn't making sense.  Yes I have SET
OPTIMIZE ON.

Solution, solution, who's got the solution?

Brian



Tue, 08 Aug 2000 03:00:00 GMT  
 VFP Rushmore optimization not kicking in

Brian,

You're right, it doesn't make sense. I just copied your code and ran a test
and VFP reported full optimization.You're sure that there's a tag on cust_id
and that it hasn't been changed to UPPER(Cust_Id) or something like that?

--
Josh Weiss
Boston Microcomputer Consulting

http://emporium.turnpike.net/~bmc

Remove XXX from e-mail address when replying

Quote:

>I'm new to VFP and I'm trying to do something very simple (!).  When I
>do the following in the command window I get the message that the
>Rushmore optimization level is none.

>sys(3054,1)
>select company,cust_id from customer where cust_id = "ANTON" into cursor
>temp

>This customer table is the one that ships with VFP and is in the
>samples\data folder.  It has a tag on cust_id.  If I add a tag to the
>file called Deleted with deleted() as the key and do the same thing I
>get partial optimization.  This isn't making sense.  Yes I have SET
>OPTIMIZE ON.

>Solution, solution, who's got the solution?

>Brian



Tue, 08 Aug 2000 03:00:00 GMT  
 VFP Rushmore optimization not kicking in


says...

Quote:
> sys(3054,1)
> select company,cust_id from customer where cust_id = "ANTON" into cursor
> temp

Is there indeed a index on cust_id, and is the expression not changed?
Wat is the value of SET("EXACT")? If it is ON, do a SET EXACT OFF and you
have full speed again.
--
Groetjes,
   Wim de Lange

(remove _noSpam before replying)



Fri, 11 Aug 2000 03:00:00 GMT  
 
 [ 3 post ] 

 Relevant Pages 

1. Rushmore optimization ?

2. Rushmore Optimization and Sys(3054,1)

3. Rushmore Optimization on Views

4. SYS(3054) - Rushmore Optimization

5. Rushmore optimization

6. Rushmore optimization problem

7. SQL Joins and Rushmore Optimization

8. Help with Rushmore Optimization

9. optimization not working (foxpro 2.6)

10. Rushmore is Not Optimizing

11. VFP buffered access and Rushmore

12. How to kicked out other users from application

 

 
Powered by phpBB® Forum Software