Clipper program run very slow in a XP machine 
Author Message
 Clipper program run very slow in a XP machine

Hi all,

In my network i have a Nt4.0 workstation PC with a Clipper program ,
my problem is:
1)when i run the program in a Win98 PC, the program works fine.
2)when i run the program in a XP PC my program runs slow, very slow
3)I have a shortcut to the clipper program
4)When i copy the Exe's files to the XP machine and the DBF files stay
in the Nt4.0 machine the problem is the same.

Where is the problem?
Please Help me
Thanks in advance

Paulo Oliveira



Fri, 22 Apr 2005 20:03:24 GMT  
 Clipper program run very slow in a XP machine


Quote:
>Hi all,

>In my network i have a Nt4.0 workstation PC with a Clipper program ,
>my problem is:
>1)when i run the program in a Win98 PC, the program works fine.
>2)when i run the program in a XP PC my program runs slow, very slow
>3)I have a shortcut to the clipper program
>4)When i copy the Exe's files to the XP machine and the DBF files stay
>in the Nt4.0 machine the problem is the same.

>Where is the problem?
>Please Help me
>Thanks in advance

>Paulo Oliveira

Hello Paulo,

Do you have the source code for the application? Is it Clipper version
5.2x?

Perhaps this extract from the VFAQ will help you....

* My application is hogging the CPU, what can I do?

  Example Google search:

<URL:http://groups.google.com/groups?q=cpu+hog+group%3Acomp.lang.clipper>

  Short answer:
  Get OSLib <URL:http://www.davep.org/clipper/#OSLib> and look
  at OL_Yield() <URL:http://www.davep.org/clipper/OSLib/OL_Yield.html>
and
  OL_AutoYield()
<URL:http://www.davep.org/clipper/OSLib/OL_AutoYield.html>.

  Short answer:
  Grab MULTI102.ZIP
<URL:http://www.the-oasis.net/files/general/multi102.zip>.

Regards,

Ross McKenzie
ValuSoft
Melbourne Australia



Fri, 22 Apr 2005 20:13:27 GMT  
 Clipper program run very slow in a XP machine
Maybe this is an opportunity to upgrade your user/s to a re-write in Delphi
or XBase++, good revenue source!
As I am at retirement stage (69) - although still programming (I can talk).

Best regards
Colin Bompas
Associated Software Consultants cc
031 2669381  0834598459


Quote:
> Hi all,

> In my network i have a Nt4.0 workstation PC with a Clipper program ,
> my problem is:
> 1)when i run the program in a Win98 PC, the program works fine.
> 2)when i run the program in a XP PC my program runs slow, very slow
> 3)I have a shortcut to the clipper program
> 4)When i copy the Exe's files to the XP machine and the DBF files stay
> in the Nt4.0 machine the problem is the same.

> Where is the problem?
> Please Help me
> Thanks in advance

> Paulo Oliveira



Sat, 23 Apr 2005 03:11:43 GMT  
 Clipper program run very slow in a XP machine
This is what Klas Engwall wrote earlier:

The most common printing problem in a network environment is that
_nothing_ reaches the printer until the application is terminated or
the spooler times out, whichever comes first. This problem is solved
by opening the port before printing and closing it afterwards.
set printer to lpt1: // or whatever port is used
set device to printer
DoThePrinting()
eject
set device to screen
set printer to // this is where the port is closed

The first line is as important as the last one, otherwise the Clipper
runtine won't know which port to close at the end.

Another speed related thing to consider is that Clipper hogs the
processor up to almost 100% even when the application is idle, and
that causes _other_ applications to slow down considerably. I mention
this since it is something you don't notice if you are only running
one application at a time and your problem description fits this
condition too.

One way to reduce the hogging is to use FT_IAmIdle() from the Nanforum
Toolkit. Instructions, the latest patch for that function and download
links for the whole lib are available here:
http://home.swipnet.se/engw/clipper/nfpat1a.htm

HTH,
Klas


Quote:
> Hi all,

> In my network i have a Nt4.0 workstation PC with a Clipper program ,
> my problem is:
> 1)when i run the program in a Win98 PC, the program works fine.
> 2)when i run the program in a XP PC my program runs slow, very slow
> 3)I have a shortcut to the clipper program
> 4)When i copy the Exe's files to the XP machine and the DBF files stay
> in the Nt4.0 machine the problem is the same.

> Where is the problem?
> Please Help me
> Thanks in advance

> Paulo Oliveira



Sat, 23 Apr 2005 04:59:54 GMT  
 Clipper program run very slow in a XP machine
Paulo,

Quote:
>In my network i have a Nt4.0 workstation PC with a Clipper program ,
>my problem is:
>1)when i run the program in a Win98 PC, the program works fine.
>2)when i run the program in a XP PC my program runs slow, very slow
>3)I have a shortcut to the clipper program
>4)When i copy the Exe's files to the XP machine and the DBF files stay
>in the Nt4.0 machine the problem is the same.

>Where is the problem?

It looks like it is in the XP machine <g>. But seriously, there are at
least two possibilities in addition to what the other guys said:

The antivirus software may be interfering and causing long delays when
you open files (especially Norton Antivirus 2001, but it looks like
the 2003 version can again be configured to avoid this). Disable it
temporarily to see if it makes any difference.

I read somewhere that there is a bug in XP that makes it dead slow
when accessing files the way we do with Clipper. I am not sure if this
applies to XP as a workstation or XP as a server or both, though. The
bug is supposed to be fixed in SP1.

Klas

-------
klas dot engwall at engwall dot com




Sat, 23 Apr 2005 12:03:35 GMT  
 
 [ 5 post ] 

 Relevant Pages 

1. Programs Run Slower After You Install Windows XP SP-1

2. XP and slow printing from clipper program

3. Two Clipper Programs run slow under Win sistems.

4. How can I compile a clipper program to run on a UNIX machine

5. slow running in XP?

6. I can't install LabVIEW 6.1 on a new Dell Machine running XP pro

7. Upgrading XP machine to run gcc

8. Windows XP + Novell + Clipper => Slow

9. fixing slow Clipper application in XP

10. Calrion 5 programs slow on XP

11. problem at running clipper under Win XP Home

12. Clipper apps running SLOW!!!

 

 
Powered by phpBB® Forum Software