Blinker Executable Clipper link command 
Author Message
 Blinker Executable Clipper link command

Hi,

Can anyone explain if the syntax for "blinker executable clipper" link command
must follow the version syntax?  

In s87 files setting is Fxxx, in 5+ it becomes F:xxxx.  I am trying to setup a
common link file and have legacy s87 apps as well as 5.01 and  5.2 programs.  

So can I have a line that reads "blinker executable command fxxx" that would
be fine for the s87 app, but what would happen with the 5.01 app?

any thoughts?

Henry Boyd

**********************************************************************

PO 629, Ipswich, MA 01938 USA         http://www.*-*-*.com/
**********************************************************************



Tue, 16 Nov 1999 03:00:00 GMT  
 Blinker Executable Clipper link command


Quote:
>Hi,

>Can anyone explain if the syntax for "blinker executable clipper" link command
>must follow the version syntax?  

>In s87 files setting is Fxxx, in 5+ it becomes F:xxxx.  I am trying to setup a
>common link file and have legacy s87 apps as well as 5.01 and  5.2 programs.  

>So can I have a line that reads "blinker executable command fxxx" that would
>be fine for the s87 app, but what would happen with the 5.01 app?

The old syntax is recognized still under 5.x. They said it isn't
supported in the manuals, but it is.

Also, you might like to try PBMake, which allows you to put:

#ifdef S87
   blinker executable command fxxx
#else
   blinker executable command //f:xxx
#endif

right into your link script, even if your linker doesn't support these
constructs. (which none do, btw)

PBMake is the easiest and fastest make engine, and can support
multiple languages from a single make script.

The .MAK files can also use:

#ifdef S87
   lib c:\clipper\clipper.lib
#else
   lib c:\cl52\lib\clipper.lib
#endif

This unaddressed problem was giving problems to programmers for years.
So instead of waiting for all of the product providers to fix the
problem, I created PBMake, which is freeware and available on my www
site.



Wed, 17 Nov 1999 03:00:00 GMT  
 
 [ 2 post ] 

 Relevant Pages 

1. How to link the clipper 5.2e program using blinker 6

2. Blinker linked, behavior of Clipper 5.x app

3. Linking in Protected Mode with Clipper 5.2e, CATools and Blinker 4.x

4. Help Blinker Link Script Clipper 5.3

5. Clipper 5.2e, Blinker 4.1, W2K and the run-command

6. Command line variables to executables,command programs

7. Clipper DLL's using Clipper 5.2e and Blinker 5.10

8. error r6003 and blinker executable extended

9. decompression on compressed Blinker executables ?

10. BLINKER EXECUTABLE COMPRESS

11. Link problem with Blinker 5.1

12. Blinker linking single programmes

 

 
Powered by phpBB® Forum Software