Problems using Clipper 5.3b + Blinker 5.1 
Author Message
 Problems using Clipper 5.3b + Blinker 5.1

I have a program written in Clipper 5.2 where I use Blinker 5.1 to link
with a lib written in MSVC 1.52.  With this configuration the program
works fine.  But if I use the Clipper 5.3b the program doesnt work
(crash the machine).

My configuration of the Blinker 5.1 is:

OUTPUT myprogram
STACK 8192
MAP s,a

BLINKER INCREMENTAL OFF
BLINKER EXECUTABLE CLIPPER
BLINKER EXECUTABLE EXTEND

FILE myprogram.obj

SEARCH blxclpxx         # xx can be 52 or 53

LIB c:\clipxx\lib\clipper.lib
LIB c:\clipxx\lib\extend.lib
LIB c:\clipxx\lib\terminal.lib
LIB c:\clipxx\lib\dbfntx.lib
LIB c:\mylib.lib                        # written in MSVC 1.52 (It use
memory DPMI)
LIB c:\msvc\lib\llibca.lib
LIB c:\msvc\lib\oldnames.lib

Does Someone have a idea about this problem?
Why doesnt my program work with Clipper 5.3b?
Anyone can help me?

Sent via Deja.com http://www.*-*-*.com/
Before you buy.



Thu, 05 Dec 2002 03:00:00 GMT  
 Problems using Clipper 5.3b + Blinker 5.1

Quote:

>I have a program written in Clipper 5.2 where I use Blinker 5.1 to link
>with a lib written in MSVC 1.52.  With this configuration the program
>works fine.  But if I use the Clipper 5.3b the program doesnt work
>(crash the machine).

>My configuration of the Blinker 5.1 is:

>OUTPUT myprogram
>STACK 8192
>MAP s,a

>BLINKER INCREMENTAL OFF
>BLINKER EXECUTABLE CLIPPER
>BLINKER EXECUTABLE EXTEND

>FILE myprogram.obj

>SEARCH blxclpxx             # xx can be 52 or 53

>LIB c:\clipxx\lib\clipper.lib
>LIB c:\clipxx\lib\extend.lib
>LIB c:\clipxx\lib\terminal.lib
>LIB c:\clipxx\lib\dbfntx.lib
>LIB c:\mylib.lib                    # written in MSVC 1.52 (It use
>memory DPMI)
>LIB c:\msvc\lib\llibca.lib
>LIB c:\msvc\lib\oldnames.lib

llibca is the wrong library for Clipper 5.3x.

--

        Oasis WWW  http://www.the-oasis.net
         FTP Site  ftp://ftp.iag.net/pub/clipper
      Clipper FAQ  http://www.the-oasis.net/clipper.html
  Harbour Project  http://www.Harbour-Project.org

      Reality is the leading cause of stress
       among those who are in touch with it.



Thu, 05 Dec 2002 03:00:00 GMT  
 Problems using Clipper 5.3b + Blinker 5.1

This is a pretty useless response but maybe it will help:

I was also using Blinker 5.1 and upgraded from 5.2e to 5.3b and had
the problem you describe - I only had a small object file to calculate
a CRC16 made from a C source compiled with MSVC 1.52, not a lib.

I shuffled with the link script order and all of a sudden it worked -
then I put back the old order and it STILL worked. So I must have
changed something else - and I wasn't about to spend hours trying to
break it again - anyway maybe this will assist you:

# ECRW.LNK Windows touch screen (blinker)

BLINKER INCREMENTAL OFF
BLINKER CLIPPER SYMBOL OFF

DEFFILE ECRW.DEF

BLINKER EXECUTABLE CLIPPER F199
BLINKER EXECUTABLE NODELETE

OUTPUT ecrw

FILE ECRWOBJ\ecr
FILE ECRWOBJ\ecr0
FILE ECRWOBJ\ecr1
FILE ECRWOBJ\ecr2
FILE ECRWOBJ\ecr3
FILE ECRWOBJ\ecr4
FILE ECRWOBJ\ecr5
FILE ECRWOBJ\ecr6
FILE ECRWOBJ\ecr7
FILE ECRWOBJ\ecr8
FILE ECRWOBJ\ecr9
FILE ECRWOBJ\ecr10
FILE ECRWOBJ\ecr11
FILE ECRWOBJ\ecr12
FILE ECRWOBJ\ecr13
FILE ECRWOBJ\ecr14
FILE ECRWOBJ\ecr15

FILE setdatim
FILE isprn
FILE crc16
FILE dgfree
FILE class      // Topclass fix
FILE mpar       // Blinker obj (Clipper fix)

LIB DBFCDX, _DBFCDX
FILE cmxfun

LIB \alex\gtlib\gt_lib       // xor, bit manipulations

LIB c4wclass         // dont mess with the order
LIB wbrowset
LIB topclass
LIB clip4win

LIB \MSVC\LIB\LLIBCE

RC ECRW.RES

#End of link script

Note I use LLIBCE - not LLIBCA, I am not sure why? My understanding is
that LLIBCA is required.

Note also I do not have oldnames.lib as I used the /Zl compiler
option.

Quote:
>I have a program written in Clipper 5.2 where I use Blinker 5.1 to link
>with a lib written in MSVC 1.52.  With this configuration the program
>works fine.  But if I use the Clipper 5.3b the program doesnt work
>(crash the machine).

>My configuration of the Blinker 5.1 is:

>OUTPUT myprogram
>STACK 8192
>MAP s,a

>BLINKER INCREMENTAL OFF
>BLINKER EXECUTABLE CLIPPER
>BLINKER EXECUTABLE EXTEND

>FILE myprogram.obj

>SEARCH blxclpxx             # xx can be 52 or 53

>LIB c:\clipxx\lib\clipper.lib
>LIB c:\clipxx\lib\extend.lib
>LIB c:\clipxx\lib\terminal.lib
>LIB c:\clipxx\lib\dbfntx.lib
>LIB c:\mylib.lib                    # written in MSVC 1.52 (It use
>memory DPMI)
>LIB c:\msvc\lib\llibca.lib
>LIB c:\msvc\lib\oldnames.lib

>Does Someone have a idea about this problem?
>Why doesnt my program work with Clipper 5.3b?
>Anyone can help me?

>Sent via Deja.com http://www.deja.com/
>Before you buy.

Alex Strickland



Fri, 06 Dec 2002 03:00:00 GMT  
 
 [ 3 post ] 

 Relevant Pages 

1. GPF w/ Clipper 5.3b and Blinker 5.1

2. Clipper 5.3b/Blinker 5.1 and Windows

3. Clipper 5.3b - Blinker 5.1 - Windows NT

4. Clipper 5.3b + Workbench + Blinker 5.1 on Win2K SP2

5. Clipper DLL's using Clipper 5.2e and Blinker 5.10

6. BLINKER 5.1 + CLIPPER 5.3

7. Reengineer EXE linked using Blinker 5.1 ?

8. Link problem with Blinker 5.1

9. Exospace -> Blinker 5.1 problem

10. CLIPPER 5.3B / EXOSPACE Vs BLINKER

11. msetcurdor() with protected mode error Clipper 5.3b/Blinker 7.0

12. Clipper 5.3b + Six3 + Blinker 3.3

 

 
Powered by phpBB® Forum Software