Copy filename lpt1 not working under W2000 
Author Message
 Copy filename lpt1 not working under W2000

I have a F2 function key in my program that uses the proclip library to
copy the current screen contents to lpt1 (i.e. provide a printscreen
type function).  It worked under Windows 2000 for a while.  I also
tested copy [any text file] lpt1 and it also does not work.  Printing
via R&R report writer does appear to work.  I originally worked but the
client did something after installing Office 2000 and it no longer
works.  I have a W2000 machine with Office 2000 at home but it does not
have the problem.  (No error is generated and it is as if it printed).
This is like having a bad printer port.

Does anyone have any thoughts or settings to change this behavior.



Fri, 16 Jan 2004 08:04:30 GMT  
 Copy filename lpt1 not working under W2000
Cliff

sounds like your mapping &/or capturing is missing, or piped to the wrong place. Check your setups. If you can't print by typing
something like:

COPY <any_asci_text_file> LPT1  <ENTER>

then you're hosed.  Get that working and your clipper program will sing.

--
Steve McNaughton

Quote:

> I have a F2 function key in my program that uses the proclip library to
> copy the current screen contents to lpt1 (i.e. provide a printscreen
> type function).  It worked under Windows 2000 for a while.  I also
> tested copy [any text file] lpt1 and it also does not work.  Printing
> via R&R report writer does appear to work.  I originally worked but the
> client did something after installing Office 2000 and it no longer
> works.  I have a W2000 machine with Office 2000 at home but it does not
> have the problem.  (No error is generated and it is as if it printed).
> This is like having a bad printer port.

> Does anyone have any thoughts or settings to change this behavior.



Sun, 18 Jan 2004 02:37:08 GMT  
 Copy filename lpt1 not working under W2000
That is what I figured.  R&R report writer does work though from within the application.  I hoped someone had some ideas about
W2000.  Microsoft knowledgebase said to delete ptinters, including registry changes and reinstall printers.
Quote:

> Cliff

> sounds like your mapping &/or capturing is missing, or piped to the wrong place. Check your setups. If you can't print by typing
> something like:

> COPY <any_asci_text_file> LPT1  <ENTER>

> then you're hosed.  Get that working and your clipper program will sing.

> --
> Steve McNaughton


> > I have a F2 function key in my program that uses the proclip library to
> > copy the current screen contents to lpt1 (i.e. provide a printscreen
> > type function).  It worked under Windows 2000 for a while.  I also
> > tested copy [any text file] lpt1 and it also does not work.  Printing
> > via R&R report writer does appear to work.  I originally worked but the
> > client did something after installing Office 2000 and it no longer
> > works.  I have a W2000 machine with Office 2000 at home but it does not
> > have the problem.  (No error is generated and it is as if it printed).
> > This is like having a bad printer port.

> > Does anyone have any thoughts or settings to change this behavior.



Sat, 17 Jan 2004 11:01:59 GMT  
 
 [ 3 post ] 

 Relevant Pages 

1. NI VISA not seeing LPT1, although LPT1 working with Logic Analzyer Software

2. File Delete does not work in W2000

3. Printing W2000 LPT1 problem.

4. FileName as Runtime Variable not working for .tps files

5. Evaluation Copy - Example Does Not Work!

6. C4a : COPY not working

7. Copy file not working on NT/2000

8. Copying file to LPT1:

9. To copy or not to copy

10. LPT1 doesn't work under Windows ME

11. Help - LPT1.PRN can not create

12. Does not work with TPS but works with DBF

 

 
Powered by phpBB® Forum Software