Netware 4.11/Clipper 5.2e/ADS & NT workstation - Help! 
Author Message
 Netware 4.11/Clipper 5.2e/ADS & NT workstation - Help!

My customer has IBM desktops running WINNT 4 with Client32 for NT.  The
Server is a COMPAQ Pro-Liant with 2 Pentium 450 processors running Netware
4.11 and they claim the latest patches.  This server also has Advantage
Database Server version 5.6 which is used to run my Clipper 5.2e app.  This
app is running on other Netware & NT servers around the country without a
problem.

The problem:

When a user abends Netware or specifically the Advantage Server holds the
files open.  When another user tries to access the same files they get a
sharing violation, corrupted index, or access denied error.  We have to
close the connection at the Netware Console.  We are also experiencing
corrupted indexes.

Advantage had first thought it might be a TURBOFAT problem, but my customer
says the has the latest NLM.  If you try to open one of the held files you
also get access denied or sharing violation errors.

Any thoughts out there of how this site could be different?



Sat, 24 Aug 2002 03:00:00 GMT  
 Netware 4.11/Clipper 5.2e/ADS & NT workstation - Help!

Quote:

> The problem:

> When a user abends Netware or specifically the Advantage Server holds the
> files open.  When another user tries to access the same files they get a
> sharing violation, corrupted index, or access denied error.  We have to
> close the connection at the Netware Console.  We are also experiencing
> corrupted indexes.

It sounds like sometimes your programs use compatibility mode, while at other
times, they use full ADS mode. And of course if you use full ADS mode and then
try to access a file that ADS has open using a program that doesn't use ADS,
then you'll get sharing violations and/or access denied errors. And the only
way I've found to get corrupted indexes with ADS is to use compatibility mode,
so I never use compatibility mode and require all data access be done via ADS.
--
David G. Holm


Sun, 25 Aug 2002 03:00:00 GMT  
 
 [ 2 post ] 

 Relevant Pages 

1. Clipper 5.2e/ADS/ & Netware 4.11

2. Netware 4.11 & NT4 Workstations

3. Clipper & NetWare 4.11

4. Clipper 5.2e Locking up NT Workstation (Help wanted)

5. Client32, netware 4.11/3.12 and clipper

6. Converting ADS/Netware to ADS/NT

7. CPD 2.1 & NetWare 4.11

8. using novell 4.11, clipper 5.2e, blinker 3.x,

9. Clipper, NT Workstation, Netware 3

10. Clipper on NT Workstation under NetWare 4

11. DOS workstation attaching to NT 4.0 server running clipper 5.2e

 

 
Powered by phpBB® Forum Software