Link Problems with ext.LIB (CW4/CW5EE) 
Author Message
 Link Problems with ext.LIB (CW4/CW5EE)

Hi to all of you,
I observed somethin I can not explain:
AA)
I created a static lib (32bit) local; when I try to refer the modules
(functions & procs) therein as "Type:external library" the calling appl.
does not recognize the functions; defining the "Type:external DLL" (the DLL
physically does not exist!!) requires to switch
the "generate template globals and ABC's as external" ON,
then select "as lib", and
switch the "generate template globals and ABC's as external" OFF again.
Having done that the program works fine.
But activating the "generate template globals and ABC's as external" ON,
then select "as DLL" instead, and
switch the "generate template globals and ABC's as external" OFF
creates a program exception.
It is to be noticed here that "generate template globals and ABC's as
external" in both cases is OFF which, in my opinion, should have no effect -
fact is: it has!

Is there anybody who can explain this to me??

Thanks for any hint

Klaus-Thomas



Sun, 16 Dec 2001 03:00:00 GMT  
 
 [ 1 post ] 

 Relevant Pages 

1. CW5EE ODBC problem linking to Sage Line 100 accounts

2. CW4.0 and LIB problem .. Internal Error

3. Linking sqldedev.lib, desktopenginedeploy.lib to my app: unsupported recordtype 21

4. Static vs Shared: Linking tcl83s.lib vs tcl83.lib

5. Statically Linking tcl.lib and tk.lib into a standalone .exe file

6. Long File Names - problem linking dblfn.lib

7. strange Link problem (win32.lib)

8. problems linking .LIB

9. Asm and Windows ----Linking lib GP fault problem----

10. Alsys linking with metaware C and DVX socket lib problems

11. Tcl83.lib link problem

12. Link unsuported record type21 using an ext library

 

 
Powered by phpBB® Forum Software