CW 2.0 useless internal report formatter! 
Author Message
 CW 2.0 useless internal report formatter!

Hi

I have been a Clarion programmer since ver. 1 for DOS. However it does
not always seems to help me in CW 2.0.

I have tried to make a simple Address label report (1 file only)  in
CW 2.0 (2002). My labels are 89 mm wide and 36 mm high. I have no page
header or footer. Only detail (populated) and form (unpopulated) (not
sure if form is necessary).
In the report properties, I have set the prefered measure units to
Millimeters. I think it must be a bug that after saying mm units, all
units in band & report properties are correctly set to Millimeters
exept for the paper size in report properties wich still uses 1/1000
inces. This cause minor problems with having to manually converting
metric paper length to inces.

The big problem however (a bug?) is; In the 'Position' field in both
my bands (detail & form) and the 'Position' field in report properties
I have specified the size to 89 mm wide and 36 mm high (3 places with
the same info ughh) . I have done the same in report properties, but
as mentioned above (no MM untits here). So I have set the paper size
to be 3500/1000 inch wide (same as 89 mm) and 1400/1000 inch high
(same as 36 mm). I.E the 4'th place I have set the same measures.
Then I start to populate the report (detail) manually. No problem.
I set the the font to Courier New - 10 cpi. No problem. The report
looks ok in my band view. Then I do a preview and also a print. What a
result! The previewed and printed out character size does not at all
look as they did im my band view. The character size is microscopic
compared to the label size (wich I have  set 4 places) and compared to
how it looks (ok) in my band view.
Do I do something wrong here? Any suggestions will be greatly
appreciated. I have tried almost everything in two days for this (at
least initally) simple report.

I have heard many complains a bout Clarion's built in report formatter
(in usenet). If it has worked properly, I would have prefered this
instead of the separate report writer with print engines and all that
stuff. I wish my reports to be a part of (compiled into) my
application, *not* a separate part built with report writer. I can not
understand why Topspeed can't or won't build a better internal report
formatter (I think that today, it is a piece of junk full of bugs and
unlogical behavior. The much better (but separate :(  product) report
writer's  functionality should be built in to CW!! Or at least
Topspeed should address the fact that many users have problems with
even simple thing with the internal report formatter and therefore set
priorities high to fix it and doing it more logical in his behavior.

Geir Laastad/GL-Software

P.S. The labels I want is one!!! across.



Fri, 09 Jul 1999 03:00:00 GMT  
 CW 2.0 useless internal report formatter!

Hi Geir,


Quote:

>In the report properties, I have set the prefered measure units to
>Millimeters. I think it must be a bug that after saying mm units, all
>units in band & report properties are correctly set to Millimeters
>exept for the paper size in report properties wich still uses 1/1000
>inces. This cause minor problems with having to manually converting
>metric paper length to inces.

If you create a report in CW with the Wizard the DON'T CHANGE the
units from 1/1000" to mm!  All hell will break lose as the templates
and code rely only on 1/1000" and all positioning will go haywire.

I understand there are report templates around that circumvent this
bug in the template.  Since most paper sizes and stuff on this side of
the pond is in mm, this is a serious problem in CW report designer.  

I *think* you may be able to circumvent some of this by going into the
report source code and change it there, but I've had problems with
this ever since TS introduced the wizards to create reports.

Best regards,

+------------------------------------------------------------------+
|                     Arnor Baldvinsson                            |
| Mail address:  Naestrupvej 44, Sjorring, 7700 Thisted, Denmark   |
|------------------------------------------------------------------|
| e-mail:                     Web sites:                           |


+------------------------------------------------------------------+



Fri, 16 Jul 1999 03:00:00 GMT  
 CW 2.0 useless internal report formatter!

Quote:
> I understand there are report templates around that circumvent this
> bug in the template.  Since most paper sizes and stuff on this side of
> the pond is in mm, this is a serious problem in CW report designer.

> I *think* you may be able to circumvent some of this by going into the
> report source code and change it there, but I've had problems with
> this ever since TS introduced the wizards to create reports.

I just read a few lines on CIS this morning about a similar problem when
trying to adjust report properties after opening the report.  (this is
with CW 2 and may be the same for earlier versions)  The note stated
that due to a bug the calculated PROP:sizes must be adjust by *10 to get
the correct answer.  It may be worth experimenting to see if this
affects your results in a favorable manner.

--


NW Computer Resources
using CPD 2.1, LPM, CauseWay, CFD 3.1, CW 1.5, CW 2.0, CPCS, Power
Suite, G-Reg, G-Calc



Fri, 16 Jul 1999 03:00:00 GMT  
 CW 2.0 useless internal report formatter!

Hi Larry,



Quote:
>> I understand there are report templates around that circumvent this
>> bug in the template.  Since most paper sizes and stuff on this side of
>> the pond is in mm, this is a serious problem in CW report designer.

>> I *think* you may be able to circumvent some of this by going into the
>> report source code and change it there, but I've had problems with
>> this ever since TS introduced the wizards to create reports.
>I just read a few lines on CIS this morning about a similar problem when
>trying to adjust report properties after opening the report.  (this is
>with CW 2 and may be the same for earlier versions)  The note stated
>that due to a bug the calculated PROP:sizes must be adjust by *10 to get
>the correct answer.  It may be worth experimenting to see if this
>affects your results in a favorable manner.

I don't think the problem is a bug in the PROP:sizes but the design of
the report wizard template.  All the inbuilt sizes are in 1/1000" and
when a report is converted to mm these values are all out of range.  I
did some extensive tests on this and wrote a new wizard that worked
with 1.500, but didn't follow up as the 1.501 changed the templates
once again.  The only problem I found in the templates had to do with
the prefixed symbols containing set values for inches and when the
report was converted to metrics these values would somehow interfer
with the generated code and all positions would go haywire.

Best regards,

+------------------------------------------------------------------+
|                     Arnor Baldvinsson                            |
| Mail address:  Naestrupvej 44, Sjorring, 7700 Thisted, Denmark   |
|------------------------------------------------------------------|
| e-mail:                     Web sites:                           |


+------------------------------------------------------------------+



Sat, 17 Jul 1999 03:00:00 GMT  
 
 [ 4 post ] 

 Relevant Pages 

1. TEXT FIELDS LIMIT IN CW REPORT FORMATTER

2. CW 2.0 Report Controls disappear

3. CW 2.0 Report help - Reply

4. CW 2.0 Report help

5. Report to file CW 2.0??

6. CW 2.0 Report Text Length

7. CW Report Writer (2.0)

8. CW Report Writer 2.0

9. Report Writer - CW 2.0

10. Conditional Formulas In Reports in CW 2.0

11. CW 2.0 Report Writter

12. Report headers and footers (CW 1.5/2.0)

 

 
Powered by phpBB® Forum Software