What am i doing wrong. 
Author Message
 What am i doing wrong.

Hi all,

With c5ee legacy template, I have the following source in the Global
Embed/Program Setup.

if exists('c:\window\style.org')
else
copy(sub(path(),1,2)&'\windows\style.org','c:\windows\style.org')
copy('c:\windows\style.org','c:\windows\style.ini')
END

If the file style.org exists, i want nothing done.  Otherwise I need to copy
two files from the server to the workstation.  The way I have it written
now, it always does the copy even though style.org exists.  Do I need some
line of code between the if exists and else.

TIA

Don



Mon, 22 Oct 2001 03:00:00 GMT  
 What am i doing wrong.
Quote:

> if exists('c:\window\style.org')

   You forget the s in windows.

 - Andrew Guidroz II (GeeTroze)

Every pint bottle should contain a quart.
http://www.coonass.com  SnowDog Software



Mon, 22 Oct 2001 03:00:00 GMT  
 What am i doing wrong.
Oscar,

Yep, I had completly forgot about using NOT.

Thanks, I have got to leave this project for a while and refresh my mind <g>

don


Quote:
> Hello Don,

> I have those days as well so don't worry but how about:

> if ~exists('c:\window\style.org')
>    copy(sub(path(),1,2)&'\windows\style.org','c:\windows\style.org')
>    copy('c:\windows\style.org','c:\windows\style.ini')
> END

> Oscar


> >Hi all,

> >With c5ee legacy template, I have the following source in the Global
> >Embed/Program Setup.

> >if exists('c:\window\style.org')
> >else
> >copy(sub(path(),1,2)&'\windows\style.org','c:\windows\style.org')
> >copy('c:\windows\style.org','c:\windows\style.ini')
> >END

> >If the file style.org exists, i want nothing done.  Otherwise I need to
> copy
> >two files from the server to the workstation.  The way I have it written
> >now, it always does the copy even though style.org exists.  Do I need
some
> >line of code between the if exists and else.

> >TIA

> >Don



Mon, 22 Oct 2001 03:00:00 GMT  
 What am i doing wrong.
Hi Don,



Quote:
>if exists('c:\window\style.org')
>else
>copy(sub(path(),1,2)&'\windows\style.org','c:\windows\style.org')
>copy('c:\windows\style.org','c:\windows\style.ini')
>END

c:\window\style.org doesn't match c:\windows\style.org

Best regards,

Arnor Baldvinsson        
[Team Topspeed - Internet Connect]
Allerup Edb
Denmark

Check out Icetips and Icetips Knowledgebase
http://www.icetips.com
UIN nr.: 2428601



Mon, 22 Oct 2001 03:00:00 GMT  
 What am i doing wrong.
Paul,

Thanks, I thought I was the only one that had this problem.  One gets so
involved one can not see the obvious.  Now I know why publishing companies
have editors.

Thanks editors <g>

Don


Quote:
> Ahhhhh.... so I'm not the only one who suffers from brain drain
> occasionally.

> Regards
> Paul Melevende


> >Oscar,

> >Yep, I had completly forgot about using NOT.

> >Thanks, I have got to leave this project for a while and refresh my mind
> <g>

> >don



> >> Hello Don,

> >> I have those days as well so don't worry but how about:

> >> if ~exists('c:\window\style.org')
> >>    copy(sub(path(),1,2)&'\windows\style.org','c:\windows\style.org')
> >>    copy('c:\windows\style.org','c:\windows\style.ini')
> >> END

> >> Oscar


> >> >Hi all,

> >> >With c5ee legacy template, I have the following source in the Global
> >> >Embed/Program Setup.

> >> >if exists('c:\window\style.org')
> >> >else
> >> >copy(sub(path(),1,2)&'\windows\style.org','c:\windows\style.org')
> >> >copy('c:\windows\style.org','c:\windows\style.ini')
> >> >END

> >> >If the file style.org exists, i want nothing done.  Otherwise I need
to
> >> copy
> >> >two files from the server to the workstation.  The way I have it
written
> >> >now, it always does the copy even though style.org exists.  Do I need
> >some
> >> >line of code between the if exists and else.

> >> >TIA

> >> >Don



Mon, 22 Oct 2001 03:00:00 GMT  
 What am i doing wrong.
Ahhhhh.... so I'm not the only one who suffers from brain drain
occasionally.

Regards
Paul Melevende

Quote:

>Oscar,

>Yep, I had completly forgot about using NOT.

>Thanks, I have got to leave this project for a while and refresh my mind
<g>

>don



>> Hello Don,

>> I have those days as well so don't worry but how about:

>> if ~exists('c:\window\style.org')
>>    copy(sub(path(),1,2)&'\windows\style.org','c:\windows\style.org')
>>    copy('c:\windows\style.org','c:\windows\style.ini')
>> END

>> Oscar


>> >Hi all,

>> >With c5ee legacy template, I have the following source in the Global
>> >Embed/Program Setup.

>> >if exists('c:\window\style.org')
>> >else
>> >copy(sub(path(),1,2)&'\windows\style.org','c:\windows\style.org')
>> >copy('c:\windows\style.org','c:\windows\style.ini')
>> >END

>> >If the file style.org exists, i want nothing done.  Otherwise I need to
>> copy
>> >two files from the server to the workstation.  The way I have it written
>> >now, it always does the copy even though style.org exists.  Do I need
>some
>> >line of code between the if exists and else.

>> >TIA

>> >Don



Tue, 23 Oct 2001 03:00:00 GMT  
 
 [ 6 post ] 

 Relevant Pages 

1. What am I doing wrong!

2. What am I doing wrong?

3. Stupid newb question: What am I doing wrong?

4. What am I doing Wrong

5. what am i doing wrong

6. Help - What am I doing wrong

7. Saving a Variable to a field in a record- what am i doing wrong

8. What am I doing wrong?

9. What am I doing wrong?

10. #CONTROL What am I doing wrong

11. What am I doing wrong?

12. Clarion 5.5 What am I doing wrong????

 

 
Powered by phpBB® Forum Software