strange XP problem 
Author Message
 strange XP problem

I have a user who uses my Clarion 5.5H ABC app on a network. They have one
Windows XP client computer that has problems running the app. When they
start the Clarion app it shows as running in the task manager but the main
window of the app never opens. They found that if they re-install my app the
program will run fine. This works only until the computer is turned off - if
they turn off the computer they then have to reinstall the Clarion app for
it to run the next time the computer is turned on. Any help or suggestions
will be appreciated.

--
regards,

Chuck Tart
CommPay Software



Sat, 24 Dec 2005 02:23:41 GMT  
 strange XP problem
Sounds like the Clarion Linker Problem for C5 (maybe for 5.5 too).

If it is get the new linker from SV and recompile your app.

A temporary fix is below:

~~~~~~~~~~~~~~

What is happening is that Microsoft XP is saving information in the
windows/prefetch folder when a program is run.

The next time that program is called XP reads that file when it opens the
program. If XP can't understand what it previously wrote in the prefetch
file the program does not open.

To work around this problem:

Run "regedit "
Click Edit and then Search
Search for EnablePrefetcher (note this is one word)
Go to [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session
Manager\Memory Management\PrefetchParameters\EnablePrefetcher]
Set the value to 0-Disable (Other values are 1-App launch prefetch, 2-Boot
Prefetch, 3-Both)
Restart the computer

~~~~~~~~~~~~

This may help until you can recompile.

Lynn Howard


Quote:
> I have a user who uses my Clarion 5.5H ABC app on a network. They have one
> Windows XP client computer that has problems running the app. When they
> start the Clarion app it shows as running in the task manager but the main
> window of the app never opens. They found that if they re-install my app
the
> program will run fine. This works only until the computer is turned off -
if
> they turn off the computer they then have to reinstall the Clarion app for
> it to run the next time the computer is turned on. Any help or suggestions
> will be appreciated.

> --
> regards,

> Chuck Tart
> CommPay Software



Sat, 24 Dec 2005 02:44:48 GMT  
 strange XP problem
Lynn,

Thanks for the tips - I will give them a try.

--
regards,

Chuck Tart
CommPay Software

Quote:
> Sounds like the Clarion Linker Problem for C5 (maybe for 5.5 too).

> If it is get the new linker from SV and recompile your app.

> A temporary fix is below:

> ~~~~~~~~~~~~~~

> What is happening is that Microsoft XP is saving information in the
> windows/prefetch folder when a program is run.

> The next time that program is called XP reads that file when it opens the
> program. If XP can't understand what it previously wrote in the prefetch
> file the program does not open.

> To work around this problem:

> Run "regedit "
> Click Edit and then Search
> Search for EnablePrefetcher (note this is one word)
> Go to [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session
> Manager\Memory Management\PrefetchParameters\EnablePrefetcher]
> Set the value to 0-Disable (Other values are 1-App launch prefetch, 2-Boot
> Prefetch, 3-Both)
> Restart the computer

> ~~~~~~~~~~~~

> This may help until you can recompile.

> Lynn Howard



> > I have a user who uses my Clarion 5.5H ABC app on a network. They have
one
> > Windows XP client computer that has problems running the app. When they
> > start the Clarion app it shows as running in the task manager but the
main
> > window of the app never opens. They found that if they re-install my app
> the
> > program will run fine. This works only until the computer is turned
off -
> if
> > they turn off the computer they then have to reinstall the Clarion app
for
> > it to run the next time the computer is turned on. Any help or
suggestions
> > will be appreciated.

> > --
> > regards,

> > Chuck Tart
> > CommPay Software



Sat, 24 Dec 2005 02:55:18 GMT  
 strange XP problem
We had this issue on occasion on our Win2K desktops and it turned out to
happen to parts of our Clarion IDE as well. Strange as it may sound it
turned out that the .INI that stored the last known location of the window
had stored the location wrong.  basically the window got itself located to
the fartest lower right virtual corner possible.  we went in and edited the
.INI file and zeroed the window locations.  the next time the app opened it
was ok.


Quote:
> I have a user who uses my Clarion 5.5H ABC app on a network. They have one
> Windows XP client computer that has problems running the app. When they
> start the Clarion app it shows as running in the task manager but the main
> window of the app never opens. They found that if they re-install my app
the
> program will run fine. This works only until the computer is turned off -
if
> they turn off the computer they then have to reinstall the Clarion app for
> it to run the next time the computer is turned on. Any help or suggestions
> will be appreciated.

> --
> regards,

> Chuck Tart
> CommPay Software



Sat, 24 Dec 2005 03:30:18 GMT  
 strange XP problem
Lynn,

I had the user disable EnablePrefetcher (set to 0) and this made no
difference with the problem.

--
regards,

Chuck Tart
CommPay Software

Quote:
> Sounds like the Clarion Linker Problem for C5 (maybe for 5.5 too).

> If it is get the new linker from SV and recompile your app.

> A temporary fix is below:

> ~~~~~~~~~~~~~~

> What is happening is that Microsoft XP is saving information in the
> windows/prefetch folder when a program is run.

> The next time that program is called XP reads that file when it opens the
> program. If XP can't understand what it previously wrote in the prefetch
> file the program does not open.

> To work around this problem:

> Run "regedit "
> Click Edit and then Search
> Search for EnablePrefetcher (note this is one word)
> Go to [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session
> Manager\Memory Management\PrefetchParameters\EnablePrefetcher]
> Set the value to 0-Disable (Other values are 1-App launch prefetch, 2-Boot
> Prefetch, 3-Both)
> Restart the computer

> ~~~~~~~~~~~~

> This may help until you can recompile.

> Lynn Howard



> > I have a user who uses my Clarion 5.5H ABC app on a network. They have
one
> > Windows XP client computer that has problems running the app. When they
> > start the Clarion app it shows as running in the task manager but the
main
> > window of the app never opens. They found that if they re-install my app
> the
> > program will run fine. This works only until the computer is turned
off -
> if
> > they turn off the computer they then have to reinstall the Clarion app
for
> > it to run the next time the computer is turned on. Any help or
suggestions
> > will be appreciated.

> > --
> > regards,

> > Chuck Tart
> > CommPay Software



Sat, 24 Dec 2005 03:41:43 GMT  
 strange XP problem
Our application has an INI file in the root directory of the application
with a matching file name.  In it, it stores the home position for each
window the application opens.  this may just be the way this application was
designed (I'm like the third programmer on this project) .

Quote:
> John,

> My app does not use and .ini files - which one are you referring to ?

> --
> regards,

> Chuck Tart
> CommPay Software


> > We had this issue on occasion on our Win2K desktops and it turned out to
> > happen to parts of our Clarion IDE as well. Strange as it may sound it
> > turned out that the .INI that stored the last known location of the
window
> > had stored the location wrong.  basically the window got itself located
to
> > the fartest lower right virtual corner possible.  we went in and edited
> the
> > .INI file and zeroed the window locations.  the next time the app opened
> it
> > was ok.



> > > I have a user who uses my Clarion 5.5H ABC app on a network. They have
> one
> > > Windows XP client computer that has problems running the app. When
they
> > > start the Clarion app it shows as running in the task manager but the
> main
> > > window of the app never opens. They found that if they re-install my
app
> > the
> > > program will run fine. This works only until the computer is turned
> off -
> > if
> > > they turn off the computer they then have to reinstall the Clarion app
> for
> > > it to run the next time the computer is turned on. Any help or
> suggestions
> > > will be appreciated.

> > > --
> > > regards,

> > > Chuck Tart
> > > CommPay Software



Sat, 24 Dec 2005 03:57:11 GMT  
 strange XP problem
John,

My app does not use and .ini files - which one are you referring to ?

--
regards,

Chuck Tart
CommPay Software

Quote:
> We had this issue on occasion on our Win2K desktops and it turned out to
> happen to parts of our Clarion IDE as well. Strange as it may sound it
> turned out that the .INI that stored the last known location of the window
> had stored the location wrong.  basically the window got itself located to
> the fartest lower right virtual corner possible.  we went in and edited
the
> .INI file and zeroed the window locations.  the next time the app opened
it
> was ok.



> > I have a user who uses my Clarion 5.5H ABC app on a network. They have
one
> > Windows XP client computer that has problems running the app. When they
> > start the Clarion app it shows as running in the task manager but the
main
> > window of the app never opens. They found that if they re-install my app
> the
> > program will run fine. This works only until the computer is turned
off -
> if
> > they turn off the computer they then have to reinstall the Clarion app
for
> > it to run the next time the computer is turned on. Any help or
suggestions
> > will be appreciated.

> > --
> > regards,

> > Chuck Tart
> > CommPay Software



Sat, 24 Dec 2005 03:42:35 GMT  
 strange XP problem
:-(

Did he reboot?

Lynn Howard


Quote:
> Lynn,

> I had the user disable EnablePrefetcher (set to 0) and this made no
> difference with the problem.

> --
> regards,

> Chuck Tart
> CommPay Software


> > Sounds like the Clarion Linker Problem for C5 (maybe for 5.5 too).

> > If it is get the new linker from SV and recompile your app.

> > A temporary fix is below:

> > ~~~~~~~~~~~~~~

> > What is happening is that Microsoft XP is saving information in the
> > windows/prefetch folder when a program is run.

> > The next time that program is called XP reads that file when it opens
the
> > program. If XP can't understand what it previously wrote in the prefetch
> > file the program does not open.

> > To work around this problem:

> > Run "regedit "
> > Click Edit and then Search
> > Search for EnablePrefetcher (note this is one word)
> > Go to [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session
> > Manager\Memory Management\PrefetchParameters\EnablePrefetcher]
> > Set the value to 0-Disable (Other values are 1-App launch prefetch,
2-Boot
> > Prefetch, 3-Both)
> > Restart the computer

> > ~~~~~~~~~~~~

> > This may help until you can recompile.

> > Lynn Howard



> > > I have a user who uses my Clarion 5.5H ABC app on a network. They have
> one
> > > Windows XP client computer that has problems running the app. When
they
> > > start the Clarion app it shows as running in the task manager but the
> main
> > > window of the app never opens. They found that if they re-install my
app
> > the
> > > program will run fine. This works only until the computer is turned
> off -
> > if
> > > they turn off the computer they then have to reinstall the Clarion app
> for
> > > it to run the next time the computer is turned on. Any help or
> suggestions
> > > will be appreciated.

> > > --
> > > regards,

> > > Chuck Tart
> > > CommPay Software



Sat, 24 Dec 2005 04:40:29 GMT  
 strange XP problem
The problem only happens when the computer is turned off and restarted - not
when the program is exited and then run again without the computer being
restarted.

--
regards,

Chuck Tart
CommPay Software

Quote:
> :-(

> Did he reboot?

> Lynn Howard



> > Lynn,

> > I had the user disable EnablePrefetcher (set to 0) and this made no
> > difference with the problem.

> > --
> > regards,

> > Chuck Tart
> > CommPay Software


> > > Sounds like the Clarion Linker Problem for C5 (maybe for 5.5 too).

> > > If it is get the new linker from SV and recompile your app.

> > > A temporary fix is below:

> > > ~~~~~~~~~~~~~~

> > > What is happening is that Microsoft XP is saving information in the
> > > windows/prefetch folder when a program is run.

> > > The next time that program is called XP reads that file when it opens
> the
> > > program. If XP can't understand what it previously wrote in the
prefetch
> > > file the program does not open.

> > > To work around this problem:

> > > Run "regedit "
> > > Click Edit and then Search
> > > Search for EnablePrefetcher (note this is one word)
> > > Go to [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session
> > > Manager\Memory Management\PrefetchParameters\EnablePrefetcher]
> > > Set the value to 0-Disable (Other values are 1-App launch prefetch,
> 2-Boot
> > > Prefetch, 3-Both)
> > > Restart the computer

> > > ~~~~~~~~~~~~

> > > This may help until you can recompile.

> > > Lynn Howard



> > > > I have a user who uses my Clarion 5.5H ABC app on a network. They
have
> > one
> > > > Windows XP client computer that has problems running the app. When
> they
> > > > start the Clarion app it shows as running in the task manager but
the
> > main
> > > > window of the app never opens. They found that if they re-install my
> app
> > > the
> > > > program will run fine. This works only until the computer is turned
> > off -
> > > if
> > > > they turn off the computer they then have to reinstall the Clarion
app
> > for
> > > > it to run the next time the computer is turned on. Any help or
> > suggestions
> > > > will be appreciated.

> > > > --
> > > > regards,

> > > > Chuck Tart
> > > > CommPay Software



Sat, 24 Dec 2005 05:32:08 GMT  
 strange XP problem
Search your C drive for appname.ini where appname is the name of your
app. You will most likely find one or more ini files depending on what
version of Windows you are using. CW creates one even if you don't
specify one.

Gary



Sun, 25 Dec 2005 01:13:34 GMT  
 strange XP problem
The below text is the only thing in the app.ini file and the program is not
set to use .ini files anyway.

[__Dont_Touch_Me__]
Sectors=0

--
regards,

Chuck Tart
CommPay Software

Quote:
> Search your C drive for appname.ini where appname is the name of your
> app. You will most likely find one or more ini files depending on what
> version of Windows you are using. CW creates one even if you don't
> specify one.

> Gary



Sun, 25 Dec 2005 01:43:39 GMT  
 
 [ 13 post ] 

 Relevant Pages 

1. Something strange with C55 and XP

2. Strange screen size with Windows XP

3. To XP or not to XP?

4. XP Home vs XP Pro - switch ???

5. XP mean Windows XP proffessional

6. Strange, very strange

7. Version 5, Win XP and Screen Display Problem

8. icon display problem inlistbox on XP Home

9. XP problem ?

10. Are there known problems w/shellexecute on XP?

11. Windows XP Printing Problems

 

 
Powered by phpBB® Forum Software