Help - What am I doing wrong 
Author Message
 Help - What am I doing wrong

Hi all,

I have a button on a browse that calls an update form on an unrelated file.
On Selected I put the following
CW5EEb Legacy

Do Brw1::GetRecord
SHI:booked='Y'                                   !Flag the highlighted
record that a invoice record was created
put(shipper)
GlobalRequest=InsertRecord
Glo:ShipDsp=SHI:DSP
glo:shipcode=SHI:CODE
updatemoark                                    !Call the form to create the
invoice record.
glo:shipcode=' '
ForceRefresh=True
Do RefreshWindow
select(?CurrentTab)                        !Back to the shipment browse.

This works, but the next time all the fields are filled in from the previous
record.  I tried using clear(moark), but doing so stops the autoincrement
from working.

What am I doing wrong.

--
Don Harvey
Mo-Ark Truck Services, Inc.
www.moark.com



Mon, 20 May 2002 03:00:00 GMT  
 Help - What am I doing wrong
Hi, Don!

I don't know what you are doing wrong, but one way around your problem is to
save your autoincrement value to a variable, clear the record, then prime
the autoincrement field again with your variable value.

Jim Johnson

|Hi all,
|
|I have a button on a browse that calls an update form on an unrelated file.
|On Selected I put the following
|CW5EEb Legacy
|
|Do Brw1::GetRecord
|SHI:booked='Y'                                   !Flag the highlighted
|record that a invoice record was created
|put(shipper)
|GlobalRequest=InsertRecord
|Glo:ShipDsp=SHI:DSP
|glo:shipcode=SHI:CODE
|updatemoark                                    !Call the form to create the
|invoice record.
|glo:shipcode=' '
|ForceRefresh=True
|Do RefreshWindow
|select(?CurrentTab)                        !Back to the shipment browse.
|
|This works, but the next time all the fields are filled in from the
previous
|record.  I tried using clear(moark), but doing so stops the autoincrement
|from working.
|
|What am I doing wrong.
|
|--
|Don Harvey
|Mo-Ark Truck Services, Inc.
|www.moark.com
|
|
|



Mon, 20 May 2002 03:00:00 GMT  
 Help - What am I doing wrong
Try CLEAR(MOA:Record), substituting whatever the real moark prefix in place
of MOA.

HTH,


Quote:
> Hi all,

> I have a button on a browse that calls an update form on an unrelated
file.
> On Selected I put the following
> CW5EEb Legacy

> Do Brw1::GetRecord
> SHI:booked='Y'                                   !Flag the highlighted
> record that a invoice record was created
> put(shipper)
> GlobalRequest=InsertRecord
> Glo:ShipDsp=SHI:DSP
> glo:shipcode=SHI:CODE
> updatemoark                                    !Call the form to create
the
> invoice record.
> glo:shipcode=' '
> ForceRefresh=True
> Do RefreshWindow
> select(?CurrentTab)                        !Back to the shipment browse.

> This works, but the next time all the fields are filled in from the
previous
> record.  I tried using clear(moark), but doing so stops the autoincrement
> from working.

> What am I doing wrong.

> --
> Don Harvey
> Mo-Ark Truck Services, Inc.
> www.moark.com



Mon, 20 May 2002 03:00:00 GMT  
 Help - What am I doing wrong
Terry,

Bingo, works perfectly.

Many thanks.

Don


Quote:
> Try CLEAR(MOA:Record), substituting whatever the real moark prefix in
place
> of MOA.

> HTH,



> > Hi all,

> > I have a button on a browse that calls an update form on an unrelated
> file.
> > On Selected I put the following
> > CW5EEb Legacy

> > Do Brw1::GetRecord
> > SHI:booked='Y'                                   !Flag the highlighted
> > record that a invoice record was created
> > put(shipper)
> > GlobalRequest=InsertRecord
> > Glo:ShipDsp=SHI:DSP
> > glo:shipcode=SHI:CODE
> > updatemoark                                    !Call the form to create
> the
> > invoice record.
> > glo:shipcode=' '
> > ForceRefresh=True
> > Do RefreshWindow
> > select(?CurrentTab)                        !Back to the shipment browse.

> > This works, but the next time all the fields are filled in from the
> previous
> > record.  I tried using clear(moark), but doing so stops the
autoincrement
> > from working.

> > What am I doing wrong.

> > --
> > Don Harvey
> > Mo-Ark Truck Services, Inc.
> > www.moark.com



Mon, 20 May 2002 03:00:00 GMT  
 
 [ 4 post ] 

 Relevant Pages 

1. What am I doing wrong!

2. What am I doing wrong?

3. Stupid newb question: What am I doing wrong?

4. What am I doing Wrong

5. what am i doing wrong

6. Saving a Variable to a field in a record- what am i doing wrong

7. What am I doing wrong?

8. What am I doing wrong?

9. #CONTROL What am I doing wrong

10. What am i doing wrong.

11. What am I doing wrong?

12. Clarion 5.5 What am I doing wrong????

 

 
Powered by phpBB® Forum Software